[pulseaudio-discuss] Command Line Language Volume 2

Max Kempter kxam at gmx.net
Thu Dec 14 05:24:13 PST 2006


to connect a host with 
„arecord -Dpulse -r48000 -fS16_LE -c2 | pacat -p -s --rate=48000 --channels=2 –format=s16le“

It was the exact idea that pacat and arecord have different defaults. And so the data is not compatible.
But this isn`t a satisfied solution for me. Because to initiate a connection with a command like this, needs a long time, nearly 1 second, and the quality is poor (delay nearly more than 0.5 seconds and reverbation sound).

So I tried it with pacmd-tool and the rtp-send-module, but I had 
some trouble with it, because I want only connect one or two hosts
at the same time. 
Actually no problem with the parameter destination=“multicast address“ (rtp-send....). But for this I have to install a router, where I can define the multicast adresses ?! It`s a good idea for big networks, but I have only few hosts in the same domain.
Is there a possibilty to set the multicast adresses locally? You know a HOWTO?

I also tried to set instead the multicast address the local host ip, but of course this doesn`t  work (sendmsg() failed: in the rtp.c: and sap.c).
This is pity because with this I had solved all my problems.    

Ideas for my problem are very welcome. 




Pierres question in last mail.

> > The second strange thing is that the Latency (I see it through -v) goes up to endless, or till I push CTRL-C.
> > 
>Pierre: This shouldn't happen though. Can you check the latency on "out" when this happens?

The latency of the "out"-modules is normal, I thing it was the prob with incompatible data.
"Ein Herz für Kinder" - Ihre Spende hilft! Aktion: www.deutschlandsegelt.de
Unser Dankeschön: Ihr Name auf dem Segel der 1. deutschen America's Cup-Yacht!

More information about the pulseaudio-discuss mailing list