[pulseaudio-discuss] Gnome volume applet

Bill Moseley moseley at hank.org
Fri Dec 21 10:25:42 PST 2007

I've been trying to get a grasp of how all the parts work -- but ALSA
and ESD and Pulse are all things I have not looked at before it's a
bit of work to grok all at once.  Is there a "big picture" doc some
place?  Knowing how things are hooked together would likely help quite
a bit.

So, the volume applet in GNOME doesn't work.  But, if I run alsamixer
from the command line it only shows a single volume control and the
device is listed as Pulse, and it works.

http://pulseaudio.org/wiki/PerfectSetup has a few comments about
GNOME.  It says to create this symlink:

    $ ln -sf /usr/local/bin/esdcompat /usr/bin/esd

Now, I'm not clear about that.  That link is set in the LTSP *client*
only, not on the LTSP server.

In LTSP, GNOME and the volume applet are running on the server.
Should that link be on the LTSP server, instead?

So in the client chroot:

$ ls -l /opt/ltsp/i386/usr/bin/esdcompat
-rwxr-xr-x 1 root root 2655 2007-06-28 10:02 /opt/ltsp/i386/usr/bin/esdcompat

$ ls -l /opt/ltsp/i386/usr/bin/esd
lrwxrwxrwx 1 root root 9 2007-11-01 18:02 /opt/ltsp/i386/usr/bin/esd -> esdcompat

And in the server:

$ ls -l /usr/bin/esd
ls: /usr/bin/esd: No such file or directory

ls -l /usr/bin/esdcompat
ls: /usr/bin/esdcompat: No such file or directory

I tried creating that symlink on the server, restarted GNOME (logged
out and back in) and still no luck.

So, I need a bit more hand holding.

Bill Moseley
moseley at hank.org

More information about the pulseaudio-discuss mailing list