[pulseaudio-discuss] ALSA with Pulseaudio in Debian Etch

Paul Jones raptorman18 at gmail.com
Thu Feb 15 11:06:52 PST 2007

Wow! I would like to thank everyone for replying so quickly and so well.
These are the quickest replies I have ever received.

Anyway, I checked my ALSA base and Plugins and they are both new enough
versions, so I am pretty sure I have the Pulse plugin.

When I use aplay with /.asoundrc, regardless of whether the Pulseaudio
server is running I get the following error.

Paul:/home/paul# aplay -D pulse /usr/share/sounds/startup3.wav
ALSA lib pcm.c:2143:(snd_pcm_open_noupdate) Unknown PCM pulse
aplay: main:550: audio open error: No such file or directory

However, out of curiosity I copied ./asoundrc to /etc/asound.conf, then
tried aplay with Pulseaudio running and it worked, but if Pulseaudio is not
running, I recieve the following error message.

Paul:/home/paul# aplay -D pulse /usr/share/sounds/startup3.wav
*** PULSEAUDIO: Unable to connect: Connection refused
aplay: main:550: audio open error: Connection refused

I also get this error message if I stop and then start the message again.
So, the aplay command only works using /etc/asound.conf and when I first
start the computer. (Pulseaudio automatically starts too.)

I always believed my soundcard was capable of hardware mixing, but it is
possible that I have been living a lie. Is there anyway I can find out for
sure? I have a Guillemot Hercules Gamesurround Muse XL, if that helps.

Let's say that I don't have hardware mixing and I have to use dmix. How
would I set up ALSA/dmix/Pulseaudio for maximum speed to solve any type of
stuttering problems, etc.

Thanks in advance.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20070215/27139a6f/attachment.htm>

More information about the pulseaudio-discuss mailing list