[pulseaudio-discuss] SHM Error Messages

Jim Duda jim at duda.tzo.com
Mon Apr 21 05:41:35 PDT 2008


I do have the mount point:
/dev/shm on /dev/shm type tmpfs (rw)

My /dev/shm has:
-r-------- 1 jduda jduda 2097176 2008-04-21 08:31 pulse-shm-3230492922
-r-------- 1 jduda jduda 2097176 2008-04-21 08:30 pulse-shm-4012357765

Each new audio attempt creates a new enter in /dev/shm, so, changing 
permissions has no affect.

Using the disable-shm in daemon.conf didn't have any affect, I get the 
same error messages.  I also tried --disable-shm=1 on the command line 
when launching pulse.

  3302 ?        S<sl   0:00 /usr/bin/pulseaudio --log-target=syslog -D 

pstream.c: Recieved SHM frame on a socket where SHM is disabled.

Thanks for the feedback.  Very strange, I don't know what I could have 
done, but I broke something.


Tanu Kaskinen wrote:
> On Sun, Apr 20, 2008 at 09:04:14PM -0400, Jim Duda wrote:
>> I don't know what I have done now, but suddenly sound stopped working on 
>> my desktop fc8 computer.  I must have changed some setting ...
>> I'm getting this message in /var/log/messages whenever I try to play 
>> anything.  Can anyone tell me what this message indicates?
>>   pstream.c: Recieved SHM frame on a socket where SHM is disabled.
> I do not know what that indicates. I've seen that problem
> once earlier at #pulseaudio, and in that case everything
> seemed fine. I'm not a shared memory expert, so for me
> "everything" means the following (you can check these too):
> /dev/shm is mounted as tmpfs and the permissions are correct
> (i.e. the same as on my own machine):
> drwxrwxrwt 3 root root 80 21.4. 05:40 /dev/shm
> A workaround which should get your sound back is to
> uncomment (the semicolon is a comment character!) the
> disable-shm line in daemon.conf and set the value to "yes".

More information about the pulseaudio-discuss mailing list