[pulseaudio-discuss] Pulseaudio, asserts and Gentoo

Rafał Mużyło galtgendo at o2.pl
Tue Sep 2 10:38:29 PDT 2008

While most of my posts here simply get ignored
(maybe most of them ARE stupid questions,
but I wouldn't mind if somebody pointed out
WHY exactly are they stupid), I'll still
try to add my 2c to this discussion.

On Gentoo, ever since alsa-plugins 1.0.12,
pulse plugin is compiled with -DNDEBUG.
The comment in the ebuild is:
# For some reasons the polyp/pulse plugin does fail with alsaplayer with
# a failed assert. As the code works just fine with asserts disabled,
# for now disable them waiting for a better solution.

I don't know, if the original problem is still valid,
but when I recently tried to build it without it,
while most of the apps worked, all of openal-based
didn't. But when I simply removed
assert(pcm->last_size >= (size * pcm->frame_size));
in pcm_pulse.c, those apps worked again and the sound seems fine.
The most annoying thing was that asserts brought down whole
apps not just sound.

More information about the pulseaudio-discuss mailing list