[pulseaudio-discuss] Pulseaudio, asserts and Gentoo

Lennart Poettering lennart at poettering.net
Tue Sep 2 12:52:28 PDT 2008

On Tue, 02.09.08 19:38, Rafał Mużyło (galtgendo at o2.pl) wrote:

> While most of my posts here simply get ignored (maybe most of them
> ARE stupid questions, but I wouldn't mind if somebody pointed out
> WHY exactly are they stupid), I'll still try to add my 2c to this
> discussion.

Any particular post you are referring to that got ignored and shouldn't?

> On Gentoo, ever since alsa-plugins 1.0.12, pulse plugin is compiled
> with -DNDEBUG.
> The comment in the ebuild is:
> # For some reasons the polyp/pulse plugin does fail with alsaplayer with
> # a failed assert. As the code works just fine with asserts disabled,
> # for now disable them waiting for a better solution.
> I don't know, if the original problem is still valid, but when I
> recently tried to build it without it, while most of the apps
> worked, all of openal-based didn't. But when I simply removed
> assert(pcm->last_size >= (size * pcm->frame_size)); in pcm_pulse.c,
> those apps worked again and the sound seems fine.  The most annoying
> thing was that asserts brought down whole apps not just sound.

That assert is not correct indeed. It has been added there (not by me
btw) under an invalid assumption about how buffering in PA works.

I reworked the alsa plugin completely in a local git tree here, which
fixes quite a few bugs, including this one. Still need to clean that
up and post it on alsa-devel.


Lennart Poettering                        Red Hat, Inc.
lennart [at] poettering [dot] net         ICQ# 11060553
http://0pointer.net/lennart/           GnuPG 0x1A015CC4

More information about the pulseaudio-discuss mailing list