[pulseaudio-discuss] 64-bit Flash 10 and PulseAudio

Lennart Poettering lennart at poettering.net
Tue Jul 28 07:50:25 PDT 2009

On Thu, 23.07.09 16:09, Tanu Kaskinen (tanuk at iki.fi) wrote:

> Hello,
> This message contains, after some redundant blather, a hack to make
> 64-bit Flash (my version is 10.0 r22) use PulseAudio for sound output. I
> haven't heard of this hack before, so I decided to share it.
> A little while ago I tried to install 64-bit Flash 10. I couldn't make
> it play through PA, which was odd since I had heard Flash 10 should work
> fine with PA. I figured that maybe only the 32-bit version works well.
> Installing the 32-bit version seemed very complicated, because the
> needed Debian packages for a 32-bit execution environment were
> uninstallable, so I didn't manage to do that. Luckily I found a program
> that could rip the content I wanted. For Finnish readers' information:
> the content is from YLE Areena; if you're interested in the ripping
> program, google for "rtmpdump-yle".
> Yesterday that program stopped working. The content I so badly want is
> audio-only, so I should be able to record it with PA while playing it in
> a web browser, if I only could make Flash use PA. I saw people claiming
> around the net that the 64-bit version worked fine too, but as I tried
> again today, it didn't work any better than before. I wonder what could
> be different in my machine compared to those others.
> Anyway, I figured that maybe Iceweasel would print some interesting
> error messages when run from a terminal window. That it did. I got a
> flood of the following error from libasound:
> ALSA lib pcm_dmix.c:1008:(snd_pcm_dmix_open) unable to open slave
> So Flash doesn't seem to use the hardware directly after all! Instead,
> it seems to be hardcoded to use dmix. (Hey Adobe, WTF is so hard in
> using the default device??) I added this to ~/.asoundrc:

Hmm. This is not necessary here. Have you checked with strace if flash
might be looking for some specific libraries lying around? Maybe this
is some lib64/ vs lib/ fuckup? (iirc the adobe guys develop on fedora,
so maybe they hardcoded some path there)

> pcm.!dmix {
>     type pulse
> }
> And it worked!


Lennart Poettering                        Red Hat, Inc.
lennart [at] poettering [dot] net
http://0pointer.net/lennart/           GnuPG 0x1A015CC4

More information about the pulseaudio-discuss mailing list