[pulseaudio-discuss] KDE deleted my audio card?!?

Valent Turkovic valent.turkovic at gmail.com
Fri Sep 4 08:18:49 PDT 2009

I have MS-1221 (PR200) laptop that I need to fix for my sister so that
Skype works.

The issues were
- webcam didn't work
- audio didn't work on skype

I installed 2.6.31 kernel - that fixed webcam issue now cheese and
skype work ok with webcam.

After installing new Skype 2.1 beta sound didn't work until I disabled
in skype "Allow Skype to automatically adjust my mixer levels", after
that it worked without problems.

Then I tried using skype (and other audio recording applications on
Fedora) but couldn't record audio from internal microphone, but when I
connected external microphone audio recording (and skype) worked.

So I had everything working ok, except that I couldn't record from
internal microphone...

I googled around and tried a few parameters for snd-hda-intel module,
but internal microphone still didn't work, but that was acceptable. I
was doing all configuration while in Gnome, and now I had working
audio and video for skype, and also working audio recording (via
external mice) and working webcam for cheese, skype and other
applications that use webcam.

Then I switched into KDE, without restart, just log off and login to
KDE. KDE immediately popped up a window saying:
KDE detected that one or more internal sound devices were removed:
* Output: HDA Intel, INTEL HDMI (HDMI Audio Output)

And now sound was gone!

I tried reloading snd-hda-intel module, logging back to gnome,
restarting... nothing!

There is absolutely no sound output!

Now can I troubleshoot and fix this?

Why and how can KDE interfere with PulseAudio so much that it also
messes up sound in Gnome?!?
This has really pissed me off!

Any suggestions are more than welcome, so please give any suggestions you have.

Also if you need more info just tell me what do you need.


Here is some extra info:

Smolt profile for laptop:


/etc/modprobe.d/dist.conf (modprobe.conf is depracated)

by default the options file isn't commented, but I tried both ways,
and it is the same:
alias char-major-116-* snd
alias sound-service-*-0 snd-mixer-oss
#options snd-hda-intel model=laptop-eapd probe_mask=1

pratite me na twitteru - www.twitter.com/valentt
linux, blog, anime, spirituality, windsurf, wireless
registered as user #367004 with the Linux Counter, http://counter.li.org.
ICQ: 2125241, Skype: valent.turkovic, msn: valent.turkovic at hotmail.com

More information about the pulseaudio-discuss mailing list