[pulseaudio-discuss] KDE deleted my audio card?!?

Colin Guthrie gmane at colin.guthr.ie
Fri Sep 4 09:32:54 PDT 2009

'Twas brillig, and Valent Turkovic at 04/09/09 16:18 did gyre and gimble:
> After installing new Skype 2.1 beta sound didn't work until I disabled
> in skype "Allow Skype to automatically adjust my mixer levels", after
> that it worked without problems.

There are actually two problems here, one in pulseaudio and one in skype.

The one in pulseaudio has been fixed (we didn't gracefully handle when a 
client sent us a volume change request with an invalid channel map). 
This patch is now in git master and has also been backported to 0.9.15 
in the 0.9.15-stable branch in git. Packages are recommended to include 
all patches from this branch and apply them on top of the 0.9.15 tarball.

The second bug was in skype. I've been working with the skype devs today 
and we've found and fixed the source of the problem too.

So, either update pulse, or wait for the next skype beta. Or just keep 
the ticky box disabled :)

> Then I tried using skype (and other audio recording applications on
> Fedora) but couldn't record audio from internal microphone, but when I
> connected external microphone audio recording (and skype) worked.

Try changing the port in pavucontrol if you are using git master. I 
suspect that this is the missing link. You'll need the latest pulseaudio 
and pavucontrol for this.

> Then I switched into KDE, without restart, just log off and login to
> KDE. KDE immediately popped up a window saying:
> KDE detected that one or more internal sound devices were removed:
> * Output: HDA Intel, INTEL HDMI (HDMI Audio Output)

KDE (or rather phonon) integration with pulse is pretty bad. We (in 
Mandriva) deliberately cripple phonon when pulse is in use as to leave 
it in it's current form is just confusing for both users and the 
software itself.

> Why and how can KDE interfere with PulseAudio so much that it also
> messes up sound in Gnome?!?
> This has really pissed me off!

I really don't know what it could have done. Does phonon mess with your 
~/.asoundrc? I would hope not but you never know.

Try using aplay -L to list the outputs and make sure that pulse is both 
running and specified as the default output via aplay -L


Colin Guthrie

Day Job:
   Tribalogic Limited [http://www.tribalogic.net/]
Open Source:
   Mandriva Linux Contributor [http://www.mandriva.com/]
   PulseAudio Hacker [http://www.pulseaudio.org/]
   Trac Hacker [http://trac.edgewall.org/]

More information about the pulseaudio-discuss mailing list