[pulseaudio-discuss] Pulse and bluetooth on Debian

Cameron Hutchison lists at xdna.net
Sat Sep 12 00:13:55 PDT 2009

Lennart Poettering <lennart at poettering.net> writes:

>On Sun, 23.08.09 00:46, Cameron Hutchison (lists at xdna.net) wrote:

>> PulseAudio does not see the headset though. I have the appropriate
>> bluetooth modules installed, but they seem to have trouble talking to
>> bluetoothd. If I start the pulseaudio daemon manually with verbose
>> debugging and with the bluetooth headset connected, pulseaudio seems to
>> get stuck for about 15-20 seconds trying to do its bluetooth stuff:

>> [...]

>Seems the bt stack signalled us some kind of error. YOu might want to
>run bluetoothd in debug mode (-nd) to figure out what is going
>on. Checking "dmesg" is probably a good idea, too.

It appears to have been somewhere in the bt stack.

I unplugged my BT dongle, and plugged in the one I have for my netbook,
and everything worked fine. I went back to my old dongle, ...and
everything worked fine.

There may have been some global state that got reset by changing the
adapter - I don't know.

BTW. The adapter that didn't work that now does is an ISSC adapter. I
read your previous posts about how they are broken, so perhaps it is
related to that - but it is working now and I am happy.

More information about the pulseaudio-discuss mailing list