[pulseaudio-discuss] Mic not working with PA

remrot at gmail.com remrot at gmail.com
Thu Sep 24 03:16:16 PDT 2009

I've already tried to determine the exact parameters for the alsa modules,
but I don't know to do that (lsmod and dmesg don't help). The only thing I
can do is compare the alsa-base.conf files where the options are stored, but
these files are identical, except for the 'probe_mask'. But without that I
have neither sound output nor a capture device. I also compared the
alsa-info files but again the only difference I see is 'probe_mask' related.
To be honest, the more I investigate the less sense this all makes to me.
Yesterday I tried again to record from within the live session and it works
perfectly. Even the mic volume is very loud without a boost. This is driving
me crazy...

Here are the differences within the /etc/pulse/daemon.conf file (the other
files are identical)


; rlimit-rtttime = 1000000
; rlimit-rttime = 1000000

; flat-volumes = yes
flat-volumes = no

I assume the first is a typo?? Anyway, it's commented out. And you already
noticed the flatvolumes thing, so nothing new there....

I've posted to the alsa users mailing list, maybe one of the people there
has got an idea. Thanks again for your help, if you've got any other
suggestions I'll be happy to try them out!



2009/9/24 Colin Guthrie <gmane at colin.guthr.ie>

> 'Twas brillig, and remrot at gmail.com at 23/09/09 20:55 did gyre and gimble:
>> Thx for your fast response, very much appreciated!
>>  I started the live session and collected some data. I'll attach an
>> archive containing the output of 'pacmd list' from both systems as well as
>> the output of the ALSA info script that they provide for reporting bugs.
>> Maybe that will give some useful information too...
>>  The most obvious difference I noticed was within alsamixer. In the live
>> session all devices have been correctly detected, including the capture
>> device. After the installation I had to use the 'probe_mask=8' option to get
>> rid of the softmodem in codec slot 0 (without that, there wasn't even a
>> capture device). But, like I already said, now everything looks OK in the
>> installed system...
> Well there are some differences I see:
> There are two differences here. The live system seems to have FLAT_VOLUME
> but the intall has it disabled. Also the live system does not support
> HW_VOLUME_CTRL but the install does...
> (although the bit above is just for output, not input).
> @@ -262,7 +262,7 @@
>                device.profile.description = "Analog Stereo"
>                device.description = "Internes Audio Analog Stereo"
>                alsa.mixer_name = "Realtek ALC861"
> -               alsa.components = "HDA:11c13026,11790001,00100700
> HDA:10ec0861,1179ff10,00100300"
> +               alsa.components = "HDA:10ec0861,1179ff10,00100300"
>                module-udev-detect.discovered = "1"
>                device.icon_name = "audio-card-pci"
> This is another difference. The alsa.components are different. Not really
> sure what they mean to be honest tho' :s
> I suspect that your probe_mode parameter seems to me to be where the
> problem is. Perhaps you can work out how the module is loaded on the live cd
> and what params it takes etc. so as to fully replicate the setup on the
> install?
> I'm a bit stumped to be honest :s
> Col
> --
> Colin Guthrie
> gmane(at)colin.guthr.ie
> http://colin.guthr.ie/
> Day Job:
>  Tribalogic Limited [http://www.tribalogic.net/]
> Open Source:
>  Mandriva Linux Contributor [http://www.mandriva.com/]
>  PulseAudio Hacker [http://www.pulseaudio.org/]
>  Trac Hacker [http://trac.edgewall.org/]
> _______________________________________________
> pulseaudio-discuss mailing list
> pulseaudio-discuss at mail.0pointer.de
> https://tango.0pointer.de/mailman/listinfo/pulseaudio-discuss
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20090924/c26dd32c/attachment.htm>

More information about the pulseaudio-discuss mailing list