[pulseaudio-discuss] How do I use PulseAudio?

Colin Guthrie gmane at colin.guthr.ie
Mon Apr 5 16:41:29 PDT 2010

'Twas brillig, and Fabrice DELENTE at 05/04/10 19:57 did gyre and gimble:
> I'm trying to use pulseaudio because alsa's softvol plugin doesn't work
> (it's a plugin that lets each app sets its output volume).
> I'm on Slackware 13.0.

Your distro should provide a stable and usable PulseAudio solution
without you having to delve into configuring things yourself.

I know nothing personally about Slackware so can't offer any specific
advice here, but you should probably ask for help initial via your
normal distro support channels.

> I downloaded, compiled and installed the pulseaudio tgz (0.9.21).

You'd be better off with the stable-queue from git. AFAIK all distro
maintainers generally include the patches from here on top of the 0.9.21

> I read the man page, and the PerfectSetup wiki page, but didn't understand
> much of what I had to do to get it working.
> I created three groups, pulse, pulse-rt and pulse-access, and put myself in
> these three groups.

The groups are not needed. These are only required for system-wide PA
daemons which are not recommended for a typical setup - per-user PA is
more appropriately.

> I put in my .asoundrc
> pcm.pulse {
>   type pulse
> }
> ctl.pulse {
>   type pulse
> }
> but trying aplay gives
> $ aplay -Dpulse .1.wav 
> ALSA lib pulse.c:229:(pulse_connect) PulseAudio: Unable to connect:
> Connection refused

This means the PA daemon is not running.

> aplay: main:590: audio open error: Connection refused
> so tried to start the binary:
> $ pulseaudio 
> W: module.c: module-detect is deprecated: Please use module-udev-detect
> instead of module-detect!
> N: alsa-util.c: Disabling timer-based scheduling because high-resolution
> timers are not available from the kernel.
> N: alsa-util.c: Disabling timer-based scheduling because high-resolution
> timers are not available from the kernel.
> E: module-console-kit.c: GetSessionsForUnixUser() call failed:
> org.freedesktop.DBus.Error.ServiceUnknown: The name
> org.freedesktop.ConsoleKit was not provided by any .service files
> E: module.c: Failed to load  module "module-console-kit" (argument: ""):
> initialization failed.
> E: main.c: Module load failed.
> E: main.c: Failed to initialize daemon.

And this tells you why. The console kit integration is not working. You
need to make sure consolekit and dbus are working first.

Also get yourself a better kernel. You really need high resolution
timers enabled.

> I also tried as root:

Don't run it as root, just as your normal user.

> What do I do now?

Well the first port of call is via distro support channels. Once you've
fixed the problems above it should be plain sailing.



Colin Guthrie

Day Job:
  Tribalogic Limited [http://www.tribalogic.net/]
Open Source:
  Mandriva Linux Contributor [http://www.mandriva.com/]
  PulseAudio Hacker [http://www.pulseaudio.org/]
  Trac Hacker [http://trac.edgewall.org/]

More information about the pulseaudio-discuss mailing list