[pulseaudio-discuss] Problem when loading module-always-sink or module-alsa-sink

Maginot Junior maginot.junior at gmail.com
Wed Mar 24 13:29:19 PDT 2010

On Tue, Mar 23, 2010 at 2:18 PM, Lennart Poettering
<lennart at poettering.net> wrote:
> On Sat, 13.03.10 14:59, Maginot Junior (maginot.junior at gmail.com) wrote:
>> Hi,
>> I'm developing a LFS system and since I installed Pulseaudio-0.9.21
> Consider upgrading to a proper distribution where all these problems
> have already been dealt with. There is no point in tracking the same
> problems over and over again if somebody else already did just that for
> you.
>> I: main.c: Machine ID is avant.
> Your D-Bus setup is very very broken. Consider upgrading to a proper
> distribution with a working D-Bus installation.
>> I: main.c: Using runtime directory /home/maginot/.pulse/avant-runtime.
>> I: main.c: Using state directory /home/maginot/.pulse.
>> I: main.c: Using modules directory /usr/lib/pulse-0.9.21/modules.
>> I: main.c: Running in system mode: no
>> W: pid.c: Stale PID file, overwriting.
>> I: main.c: Fresh high-resolution timers available! Bon appetit!
>> I: cpu-x86.c: CPU flags: MMX SSE SSE2 SSE3 SSSE3 SSE4_1
> Interesting, so you have SSE4.1 and are building for 32bit? Consider
> upgrading to a proper distribution that chose the right CPU architecture
> when compiling.
>> I: svolume_mmx.c: Initialising MMX optimized functions.
>> I: remap_mmx.c: Initialising MMX optimized remappers.
>> I: svolume_sse.c: Initialising SSE2 optimized functions.
>> I: remap_sse.c: Initialising SSE2 optimized remappers.
>> I: sconv_sse.c: Initialising SSE2 optimized conversions.
>> D: memblock.c: Using shared memory pool with 1024 slots of size 64.0
>> KiB each, total size is 64.0 MiB, maximum usable slot size is 65496
>> D: database-gdbm.c: Opened GDBM database
> Nowadays it is recommended to use tdb here, no longer gdbm. Consider
> upgrading to a proper distribution where the mainatiner already made
> sure that PA is linked against tdb.
>> '/home/maginot/.pulse/avant-device-volumes.i686-pc-linux-gnu.gdbm'
>> I: module-device-restore.c: Sucessfully opened database file
>> '/home/maginot/.pulse/avant-device-volumes'.
>> I: module.c: Loaded "module-device-restore" (index: #0; argument: "").
>> D: database-gdbm.c: Opened GDBM database
>> '/home/maginot/.pulse/avant-stream-volumes.i686-pc-linux-gnu.gdbm'
>> I: module-stream-restore.c: Sucessfully opened database file
>> '/home/maginot/.pulse/avant-stream-volumes'.
>> I: module.c: Loaded "module-stream-restore" (index: #1; argument: "").
>> D: database-gdbm.c: Opened GDBM database
>> '/home/maginot/.pulse/avant-card-database.i686-pc-linux-gnu.gdbm'
>> I: module-card-restore.c: Sucessfully opened database file
>> '/home/maginot/.pulse/avant-card-database'.
>> I: module.c: Loaded "module-card-restore" (index: #2; argument: "").
>> I: module.c: Loaded "module-augment-properties" (index: #3; argument: "").
>> N: alsa-util.c: Disabling timer-based scheduling because running inside a VM.
>> E: fdsem.c: Assertion 'pa_atomic_dec(&f->data->waiting) >= 1' failed
>> at pulsecore/fdsem.c:283, function pa_fdsem_before_poll(). Aborting.
> This smells like a broken libatomic_ops, pulled in by a too old
> compiler.
> Consider upgrading to a proper distribution where the maintainers
> already made sure that gcc natively supports atomic operations.
> Lennart
> --
> Lennart Poettering                        Red Hat, Inc.
> lennart [at] poettering [dot] net
> http://0pointer.net/lennart/           GnuPG 0x1A015CC4
> _______________________________________________
> pulseaudio-discuss mailing list
> pulseaudio-discuss at mail.0pointer.de
> https://tango.0pointer.de/mailman/listinfo/pulseaudio-discuss


Unfortunately I can't use some distro made by others. I'm working on a
project which strict demands that I build a distribution from scratch.
Sorry, but I would be very happy too if that was an option.

I'm building for 32bit because this distribution is meant to work on
many computers as possible, so building for 64bits isn't the better
way to make that happen.

I tried the exactly version of libatomic_ops that is linked on the pa
requirements page, that didn't worked out. Tried even a newer version
still the same result (the 7.x release pointed in the HP site). My GCC
version is 4.4.1, which is made to have atomic operations built in (at
least was what I was told on #pulseaudio), but still my config.log
shows that pulseaudio needs atomic_ops.

DBus is reporting machine ID as avant because its the distro codename,
and used in the dev environment. This distro will be released for
about 8k computer per month, so I really wanted to have pa support on
it, unfortunately give up of trying, so I downgraded my distro to work
only with Alsa, at least is a workaround to the first release of the
distro which will happen next month.

best regards
[ ]'s

Maginot Jr.

More information about the pulseaudio-discuss mailing list