[pulseaudio-discuss] Trying to get Pukseaudio playing nice with KDE 4.6 on Arch Linux

Gene Kodadek gkodadek at gmail.com
Mon Feb 14 07:43:26 PST 2011

On Monday, February 14, 2011 02:36:53 PM Colin Guthrie wrote:
> 'Twas brillig, and Gene Kodadek at 14/02/11 13:36 did gyre and gimble:
> > Okay, I went back and uninstalled Pulseaudio, wiped all the settings I
> > changed, and then did everything all over again.. I'm sure I followed
> > all of the steps correctly, but with exactly the same result: the only
> > sound is from Jack-aware apps; nothing else has any output at all.
> > After a reboot this is true whether Jack is running or not. There are
> > no error messages; visually the apps seemed to be working as usual. But
> > no output. The only device that shows up in System Settings ->
> > Multimedia -> Phonon -> Device Preferences is that dummy output device.
> > 
> > Look, I know I sound like a confused noob here, but in four years of
> > using Linux I've never really had any trouble with Linux sound, never
> > tried to do any fancy configuring, and have never used pulseaudio. In
> > short, I know very little about the Linux sound stack, and much of the
> > available information online is confusing and contradictory.
> Did you see Jan's reply? I suspect you're still using the wrong command
> to load the jack modules into PA.
> You need to use "pacmd" or "pactl", not "pulseaudio" itself.
> To repeat what Jan said, do not use this:
>  pulseaudio -L module-jack-sink -L module-jack-source
> but rather use:
>  pactl load-module module-jack-sink
>  pactl load-module module-jack-source
> HTHs
> Col

Ladies and gentlemen, I have sound!!! Now I'm trying to figure out how to 
automate this...

More information about the pulseaudio-discuss mailing list