[pulseaudio-discuss] Questions about no ports available to select.

David Henningsson david.henningsson at canonical.com
Wed Feb 23 21:03:29 PST 2011

On 2011-02-24 03:27, fykcee1 at gmail.com wrote:
> Hi David,
> Thanks for your work!

You're welcome!

> 2011/2/23 David Henningsson<david.henningsson at canonical.com>
>> Ok, alsa info works just as well, see wiki.ubuntu.com/Audio/AlsaInfo
> Collected, see the attachment.
>> I just sent an entry for 506e upstream to alsa-devel. You might need a second quirk on top of that, just like I added for the Dell machines, see http://mailman.alsa-project.org/pipermail/alsa-devel/2011-February/037157.html
> I tried it, but not work for me. I doubt my 506e is not the one you mentioned:
>   1. The vendor told me it's a Conexant 'CX20671-21Z', but yours is 'CX20590'.

I have no idea of what the real name of the chip is - I picked 20590 
because 506e is hexadecimal for 20590.

>   2. patch_conexant_auto works better than patch_cxt5066, the former
> doesn't break playback and bring PA sink ports, but still no source
> ports.

 From your alsa info I can note the following:

1) The node graph is just like the other 506e:s I've seen, and identical 
to the 5066 family. So the 506e patch is correct.

2) Given your pin configurations, you should add either
options snd-hda-intel model=asus
options snd-hda-intel model=thinkpad
to /etc/modprobe.d/alsa-base.conf.
That is, in addition to the 506e patch I sent to alsa-devel.

3) For some reason, parsing has gone wrong on finding the PCI subsystem 
ID. To write a quirk that does model=thinkpad permanently, we'll need 
the PCI subsystem ID for the HDA Intel device.

4) Architecture: Mips64? Never seen HDA Intel connected to anything but 
amd64/i386, but I guess it's possible :-)

Btw, feel free to move this thread to alsa-devel, as we're into ALSA 
level stuff rather than PulseAudio stuff.

David Henningsson, Canonical Ltd.

More information about the pulseaudio-discuss mailing list