[pulseaudio-discuss] Build system: Makefile.am patches

Colin Guthrie gmane at colin.guthr.ie
Mon Jan 31 09:40:56 PST 2011

'Twas brillig, and Arun Raghavan at 31/01/11 15:07 did gyre and gimble:
> Hey Colin,
> On Mon, 2011-01-31 at 13:18 +0000, Colin Guthrie wrote:
> [...]
>> Hopefully Arun can tidy it up a little later (and also remove the
>> "build" dir that currently exists with the orc.mak as I'd prefer not to
>> have a "build" directory under VC (mainly due to me always doing "rm -rf
>> build" by way of common convention). Tho' that is hardly very urgent :)
> But but but ... it's done! :)
> [...]
>>> The third patch is some more cleanup in Makefile.am. It should be
>>> applied on top of Arun's build patches that are in his orc branch he
>>> referenced in a mail to the list yesterday. I could rebase it on
>>> master, but the he has to do the same.
>> Hunk 3 didn't apply, but I fixed it up manually. I think I did it OK,
>> but you can maybe double check? (the first bit of the hunk applied fine,
>> but the second but (setting the BUILT_SOURCES to blank) I just
>> incorporated into the only place it's set by changing += to a plain =.
>> http://git.0pointer.de/?p=pulseaudio.git;a=commitdiff;h=d766b38e1ba5d483ad7eec105860e9b9f7f55702
> Those build bits have been sitting in my tree for a while, hidden behind
> the Orc-ified volume scaling bits. The hunk probably failed because
> Maarten rebased on top of my patches as he'd mentioned (thanks,
> Maarten!).
> Anyway, I've rebased my tree over current master and cherry-picked the
> build bits into a separate branch (orc-build) here, so please pull those
> if they look okay:
> http://git.collabora.co.uk/?p=user/arun/pulseaudio.git;a=shortlog;h=refs/heads/orc-build

Gah, I'm sure you've told me that in the past too and I certainly
remember Maarten saying that now I think about it... damn!

Ahh well, that'll teach me for trying to do the stuff quickly while at
my work after spending most of the weekend doing other stuff :D

Sorry for the extra hassle I've imposed and cheers for fixing it up :)

Sadly I still get an error on make distcheck... :s

 ---{ pulseaudio 1.0-dev-66-g1df413 }---

    sysconfdir:                    ${prefix}/etc
    localstatedir:                 ${prefix}/var
    System Runtime Path:           ${prefix}/var/run/pulse
    System State Path:             ${prefix}/var/lib/pulse
    System Config Path:            ${prefix}/var/lib/pulse
    Compiler:                      gcc -std=gnu99
    CFLAGS:                        -g -O2 -Wall -W -Wextra -pipe
-Wno-long-long -Winline -Wvla -Wno-overlength-strings
-Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op
-Wsign-compare -Wformat-security -Wmissing-include-dirs
-Wformat-nonliteral -Wold-style-definition -Wpointer-arith -Winit-self
-Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes
-Wstrict-prototypes -Wredundant-decls -Wmissing-declarations
-Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align
-Wstrict-aliasing=2 -Wwrite-strings -Wno-unused-parameter -ffast-math
-Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option
-I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include

    Have X11:                      yes
    Enable OSS Output:             yes
    Enable OSS Wrapper:            yes
    Enable CoreAudio:              no
    Enable Alsa:                   yes
    Enable Solaris:                no
    Enable GLib 2.0:               yes
    Enable Gtk+ 2.0:               yes
    Enable GConf:                  yes
    Enable Avahi:                  yes
    Enable Jack:                   yes
    Enable Async DNS:              yes
    Enable LIRC:                   yes
    Enable DBUS:                   yes
      Enable HAL:                  yes
      Enable BlueZ:                yes
    Enable udev:                   yes
      Enable HAL->udev compat:     no
    Enable TCP Wrappers:           yes
    Enable libsamplerate:          yes
    Enable IPv6:                   yes
    Enable OpenSSL (for Airtunes): yes
    Enable tdb:                    yes
    Enable gdbm:                   no
    Enable simple database:        no
    Enable fftw:                   yes
    Enable orc:                    yes

    System User:                   pulse
    System Group:                  pulse
    Access Group:                  pulse-access
    Enable per-user EsounD socket: yes
    Force preopen:                 no
    Preopened modules:             all

make[1]: Entering directory
make  all-recursive
make[2]: Entering directory
Making all in src
make[3]: Entering directory
  ORCC   modules/echo-cancel/adrian-aec-orc-gen.c
Could not read input file:
make[3]: *** [modules/echo-cancel/adrian-aec-orc-gen.c] Error 1
make[3]: Leaving directory
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
make[1]: *** [all] Error 2
make[1]: Leaving directory
make: *** [distcheck] Error 1

Looks like a double _top_builddir in there or similar. Not had a chance
to fix this yet. so not pushed, but if you happen to suss it out, just
ping me, otherwise I'll try and take a look this evening!

Sorry for the hassle!



Colin Guthrie

Day Job:
  Tribalogic Limited [http://www.tribalogic.net/]
Open Source:
  Mageia Contributor [http://www.mageia.org/]
  PulseAudio Hacker [http://www.pulseaudio.org/]
  Trac Hacker [http://trac.edgewall.org/]

More information about the pulseaudio-discuss mailing list