[pulseaudio-discuss] no audio after suspend and resume

Paul Menzel paulepanter at users.sourceforge.net
Wed Apr 18 04:03:24 PDT 2012

Dear Jaromír,

Am Samstag, den 14.04.2012, 22:02 +0200 schrieb Jaromír Mikeš:
> > Od: Paul Menzel <paulepanter at users.sourceforge.net>

> Sorry for not very precise report.
> Actually automatic suspend is disabled on my gnome3 system, and no
> other option for auto power saving are not set by me.
> Anyway system get "sleep" after certain time and after awaking this
> problem occurs.

again you got me confused. ;-)

First you write automatic suspend is disabled and then you write, your
system is going to sleep after a certain amount of time.

> > 1. does sound work with other applications after resume?
> Actually other application also not working after resume.
> > 2. Is that a regression or has this not been working since the
> > beginning?
> I am experiencing this on my two machines (laptop and desktop) for
> long time and hoped it will be fixed with new update.

So it seems not to be related to GNOME 3?

> > 3. What are you doing exactly? You use Iceweasel, open a movie/audio
> > file, play it in the integrated player, suspend, resume and then audio
> > does not work anymore?
> Exactly. Even trying play any wav mp3 or video file with vlc or other
> player will not produce any sound.
> "Log-out Log-in" is not enough to fix this problem. Only restart
> helps.

Judging from information in your other messages, PulseAudio seems to be
killed by some other program for some reason.

Could you check, that PulseAudio is not running by executing the
following on a command line?

        $ pulseaudio --check
        $ echo $?

If the return value differs from 0, it means that PulseAudio is not

Please try this with `autospawn` enabled and disabled. Since I would
suspect, `autospawn = yes` would restart the PulseAudio daemon after it
being killed.

If it is killed and not restarted, try to start PulseAudio manually and
look if audio will work again.

    $ pulseaudio --log-level=debug

> > Please take a look at the Debian bug tracking system [1]. Can you find a
> > report mentioning a  similar problem? If not please report a bug using
> > `reportbug pulseaudio`. Although PulseAudio the maintenance of these
> > reports are at a bad state. (I will open a separate thread about that.)
> There are at least 3 bug reports in debian which probably refer to same problem:
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=617401

This one could be similar. You could try to run some GStreamer
application like `gst-launch2` to see if you get the same error.

Also you can follow up on the report.

    $ bts show --mbox 617401 # from devscripts packages

Now import the downloaded mbox file into your mail program and answer to
the reporter *and* <617401 at bugs.debian.org>. Ask if the problem can
still be reproduced and if a solution was found.

> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=460197
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=460197

The debug messages from them seem different. But please try the proposed
solution in there.

> > I could not find the debugging page in the Wiki moved to freedesktop.org
> > [2]. So please read the Wiki pages from Fedora [3] and Ubuntu [4]. The
> > manual pages explain the options pretty well too. 
> Here is my output for $ pulseaudio -vvvvv

Again, please write down every detail. Is this before or after the
suspend and resume cycle and if you get audio or not?

> I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
> I: [pulseaudio] main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
> D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
> D: [pulseaudio] core-util.c: RealtimeKit worked.
> I: [pulseaudio] core-util.c: Successfully gained nice level -11.
> I: [pulseaudio] main.c: This is PulseAudio 1.1
> D: [pulseaudio] main.c: Compilation host: x86_64-pc-linux-gnu
> D: [pulseaudio] main.c: Compilation CFLAGS: -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security -Werror=format-security -Wall -W -Wextra -pipe -Wno-long-long -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option
> D: [pulseaudio] main.c: Running on host: Linux x86_64 3.2.0-2-rt-amd64 #1 SMP PREEMPT RT Wed Mar 28 14:02:30 UTC 2012
> D: [pulseaudio] main.c: Found 2 CPUs.
> I: [pulseaudio] main.c: Page size is 4096 bytes
> D: [pulseaudio] main.c: Compiled with Valgrind support: no
> D: [pulseaudio] main.c: Running in valgrind mode: no
> D: [pulseaudio] main.c: Running in VM: no
> D: [pulseaudio] main.c: Optimized build: yes
> D: [pulseaudio] main.c: All asserts enabled.
> I: [pulseaudio] main.c: Machine ID is 70ddd767bc94a0ba4151111000000a34.
> I: [pulseaudio] main.c: Session ID is 70ddd767bc94a0ba4151111000000a34-1334434708.578828-1836218026.
> I: [pulseaudio] main.c: Using runtime directory /home/mira/.pulse/70ddd767bc94a0ba4151111000000a34-runtime.
> I: [pulseaudio] main.c: Using state directory /home/mira/.pulse.
> I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-1.0/modules.
> I: [pulseaudio] main.c: Running in system mode: no
> E: [pulseaudio] pid.c: Daemon already running.
> E: [pulseaudio] main.c: pa_pid_file_create() failed.
> I will do other test soon (pulse-client.conf).

If that is after resume, it means PulseAudio was not killed and is

You could try MPlayer to test things. For example:

    $ mplayer -ao pulse some-audio-file.ogg
    $ mplayer -ao alsa some-audio-file.ogg

Look at `man mplayer` on how to increase the log level for certain



PS: Always paste output in the message or attach files. Please do not
use pasting Web services with mailing lists.

PPS: Let us try to stay in this thread now as all different messages are
too confusing (for me). I am sorry if that means you need to post
information again.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20120418/c535bd25/attachment.pgp>

More information about the pulseaudio-discuss mailing list