[pulseaudio-discuss] Streaming between two WinXP machines

Tanu Kaskinen tanuk at iki.fi
Tue May 15 21:17:56 PDT 2012

On Mon, 2012-05-14 at 23:32 -0400, Dave Horoschak wrote:
> On 5/13/2012 12:17 PM, Tanu Kaskinen wrote:
> > It sounds like you want to stream the microphone audio from one machine
> > to the speakers of another machine. Does module-waveout also provide a
> > source? "waveout" sounds like it's only for output, but I don't know for
> > sure.
> >
> > Assuming that module-waveout actually provides a source, you should load
> > module-tunnel-source on the speaker machine and point it to the
> > microphone machine. Now you have a proxy source on the speaker machine,
> > and the remaining task is to get the audio from the proxy source to the
> > local sink. That can be done by loading module-loopback on the speaker
> > machine.
> >
> Now we're making some progress, but I'm still not successful.  I can 
> confirm that module-waveout supplies both a sink and a source.  FWIW, 
> the source is named wave_input.
> I have my two config files setup as follows:
> Speaker machine:
> load-module module-waveout
> load-module module-tunnel-source server- source=wave_input
> load-module module-loopback
> Microphone machine:
> load-module module-waveout
> load-module module-native-protocol-tcp auth-ip-acl= 
> auth-anonymous=1
> I run pulseaudio on both machines.
> The speaker machine immediately gives me "modules/module-tunnel.c: 
> stream died" regardless of whether or not the microphone machine has PA 
> running.

That's odd. If PA is not running, I would expect it to be impossible to
establish a TCP connection between the two machines, and "stream died"
should be printed only after the TCP connection has been established.

> The microphone machine seems to come up working properly, indicating No 
> Error on socket-server.  However, as soon as I start PA on the speaker 
> machine, the microphone machine gives me "pulsecore/protocol-native.c: 
> protocol error, kicking client" and exits.

What version are you using? I think the tunnel module was broken (maybe
only for sources, I don't remember) in 1.0 or 1.1. If you're using 2.0
or the latest git version, then this is a new bug.

> Since I haven't defined any protocols, I'm not sure where the error 
> comes into play.  Do you have any idea what could be going on?

It's a violation of the native protocol. If you have protocol errors,
they are a bug in Pulseaudio. There's nothing that you can do, except
help with figuring out what exactly is broken (the error messages are
awfully uninformative...)

> Incidentally, there's no pacmd for Win like there is for Linux.  Is 
> there another way to get to the CLI?

pactl should work.


More information about the pulseaudio-discuss mailing list