[pulseaudio-discuss] /.libs/.libs/ gotcha

David Henningsson david.henningsson at canonical.com
Tue Apr 16 23:39:50 PDT 2013

On 04/16/2013 02:17 PM, Peter Meerwald wrote:
>> When running PA manually, you probably specify "-p $(pwd)/src/.libs". I have
> see 25d8de9f0b788865cc966be709cb9ca815e6e4d7
> doc: Fix suggested dl-search-path in README
>> started to get error messages from PulseAudio about this, but I don't remember
>> exactly when. Perhaps ltdl has recently been updated, or have we?
> see da5f03b7f58264217c3f23881387129c953c1f0a
> libtool 2.4 is now required
>> I tried specifying "-p $(pwd)/src" instead, but that fails in another way: the
>> ".ifexists" command in our CLI does not add a ".libs" the way ltdl does, so
>> the result is fewer errors, but then, it only loads the required modules, and
>> prefers module-detect over module-udev-detect, e g, which is quite broken.
> -p $(pwd)/src worked for me, but maybe I did not look close enough

Could you look a bit closer and see if you get a warning message saying 
that you use module-detect instead of module-udev-detect?

>> Any thoughts on the topic? Should we add ".libs" too, when looking for files
>> in ".ifexists"?
>> Or should we lower the severity of not finding modules? Perhaps write with
>> debug severity instead, and do that regardless of if we loaded a module or
>> not?

I would probably go for lowering severity + reverting the changes that 
suggest using "src" instead of "src/.libs", because there does not seem 
to be a way we can get the ".libs" string out of libtool for our own 
search (for the ".ifexists" command).

David Henningsson, Canonical Ltd.

More information about the pulseaudio-discuss mailing list