[pulseaudio-discuss] /.libs/.libs/ gotcha

Peter Meerwald pmeerw at pmeerw.net
Tue Apr 16 05:17:18 PDT 2013

> When running PA manually, you probably specify "-p $(pwd)/src/.libs". I have

see 25d8de9f0b788865cc966be709cb9ca815e6e4d7
doc: Fix suggested dl-search-path in README

> started to get error messages from PulseAudio about this, but I don't remember
> exactly when. Perhaps ltdl has recently been updated, or have we?

see da5f03b7f58264217c3f23881387129c953c1f0a
libtool 2.4 is now required

> I tried specifying "-p $(pwd)/src" instead, but that fails in another way: the
> ".ifexists" command in our CLI does not add a ".libs" the way ltdl does, so
> the result is fewer errors, but then, it only loads the required modules, and
> prefers module-detect over module-udev-detect, e g, which is quite broken.

-p $(pwd)/src worked for me, but maybe I did not look close enough

> Any thoughts on the topic? Should we add ".libs" too, when looking for files
> in ".ifexists"?
> Or should we lower the severity of not finding modules? Perhaps write with
> debug severity instead, and do that regardless of if we loaded a module or
> not?

regards, p.


Peter Meerwald
+43-664-2444418 (mobile)

More information about the pulseaudio-discuss mailing list