[pulseaudio-discuss] Scarlett interface as default device

Rodolfo Thomazelli pe.soberbo at gmail.com
Wed Mar 20 15:01:00 PDT 2013

Seems like it worked, at least for my goals.

Like you did, I tried to make changes in " install sound-slot-0
/sbin/modprobe snd-...", but nothing really changed. So I did the changes
in "options snd-... index=-2 ". In Ubuntu's audio pane the usb device is
still not listed. But now in alsamixer the default device is the usb, and
the "mataa" software is now working with it.

In fact I can't produce sounds with "mataa", but I think that this is
another problem.  If any correlated problem appears, I'll come back for get

I would like to be able to fix the problem at the root, but as I am new to the
Linux world, I would not know where to begin.

Thank you very much!

2013/3/20 Len Ovens <len at ovenwerks.net>

> On Wed, March 20, 2013 12:07 pm, Rodolfo Thomazelli wrote:
> > Hi,
> >
> > in my research I want to use an signal analyser program called "mataa",
> an
> > extension of Octave. The extension works with the default audio device.
> >
> > I have an usb audio interface called scarlett 8i6. With the help of the
> > members of the "alsa-user" list (especially Daniel Mack, in cc:), we
> > resolved some problems of Ubuntu on the device configurations. Now, the
> > usb
> > device is listed as the following log shows:
> >
> > /proc/asound/cards
> >  0 [PCH            ]: HDA-Intel - HDA Intel PCH
> >                       HDA Intel PCH at 0xf7e00000 irq 45
> >  1 [USB            ]: USB-Audio - Scarlett 8i6 USB
> >                       Focusrite Scarlett 8i6 USB at usb-0000:00:1d.0-1.2,
> > high speed
> >
> > The problem is that the usb device is not showed in Ubuntu's audio pane,
> > so
> > I can't make it the default device. Typing F6 in alsamixer, scarlett is
> > listed as well, but I can't controll it or make it the default device. I
> > think that here is an importante information: the command "aplay
> > -Dplughw:USB some-test-wave.wav" returns me sound from the device output.
> I can not tell you why your alsa device does not show up in pulseaudio, it
> may need a special profile. However, if your USB device is plugged into
> your computer all the time (from boot) you can do one of two things if
> your application will grab the default alsa device. What I do is change
> the order of card module loading. This is done in
> /etc/modprobe.d/alsa-base.conf
> There are two ways (according to on line documentation). One is to change
> the:
> install sound-slot-0 /sbin/modprobe snd-card-0
> install sound-slot-1 /sbin/modprobe snd-card-1
> etc.
> Lines and put snd-usb-audio where snd-card-0 is. I have not gotten that to
> work for me. What I did instead was tell the unwanted card to load last.
> Farther down in the file there are a bunch of lines with index=-2 at the
> end. I added these lines:
> # ensonic should not be first
> options snd-ens1370 index=-2
> I notice this next line is included twice (ubuntu 12.04):
> options snd-usb-audio index=-2
> You may want to put a # as the first character to comment it out. Then add
> a line:
> options snd-hda-intel index=-2
> It would also be worthwhile finding out why pulseaudio doesn't see the
> card.
> --
> Len Ovens
> www.OvenWerks.net
> _______________________________________________
> pulseaudio-discuss mailing list
> pulseaudio-discuss at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/pulseaudio-discuss
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20130320/21d03c39/attachment.html>

More information about the pulseaudio-discuss mailing list