[pulseaudio-discuss] To provide modules with options

Tanu Kaskinen tanu.kaskinen at linux.intel.com
Tue Mar 4 06:52:41 PST 2014

On Tue, 2014-03-04 at 15:19 +0100, Malte Gell wrote:
> Am 03.03.2014 18:09, schrieb Tanu Kaskinen:
> > On Sun, 2014-03-02 at 17:52 +0100, Malte Gell wrote:
> >> I´m playing with giving options to module module-bluez5-device.
> >>
> >> I know, normally this is loaded automatically, but I want to try
> >> preloading it in default.pa.
> >>
> >> But, when I put this line into default.pa pulseaudio does not start:
> >>
> >> load-module module-bluez5-device address=00:23:78:AB:09:A6 profile=a2dp
> >>
> >> Why does this line not work? The bluetooth MAC is correct.
> > 
> > module-bluez5-device is implemented in a way that requires
> > module-bluez5-discovery to be loaded first. module-bluez5-device can't
> > be loaded before module-bluez5-discovery has initialized certain things.
> I have loaded module-bluez5-discover first, but I still get this error
> message:
> module-bluez5-device.c: Failed to parse module arguments

This means that either the "address" or "profile" argument wasn't
recognized... and indeed, module-bluez5-device only supports the "path"
argument (I didn't remember this when I wrote the previous reply).

The module reference in the wiki was outdated in this regard, so I now
updated it (removed references to module-bluetooth-device).

> 2014-03-04T15:16:59.989390+01:00 PC-Malte pulseaudio[5632]: [pulseaudio]
> module.c: Failed to load module "module-bluez5-device" (argument:
> "address=00:23:78:AB:09:A6 profile=a2dp"): initialization failed.
> This looks like parsing the arguments failed, but the given bluetooth
> MAC adress is correct and the profile argument is also correct.
> So I have no clue why this message still appears....
> In default.pa I load module-bluez5-discover before module-bluez5-device,
> just as needed.

Even if you fix the module arguments, I think this is still not going to
work, for two reasons: 1) it takes some time before
module-bluez5-discover has initialized the necessary things, so loading
module-bluez5-device immediately after module-bluez5-discover is too
soon, and 2) module-bluez5-discover will anyway load
module-bluez5-device for the same device that you're trying to load
manually, so some kind of conflict is probable.


More information about the pulseaudio-discuss mailing list