[pulseaudio-discuss] module-remap-sink not working for surround card

Martin Klein martin.klein.de at gmail.com
Sun Jan 4 11:54:09 PST 2015


I want to split the different outputs ports of my surround card to
different sinks. For this, I'm trying to use module-remap-sink with the
following lines in my /etc/pulse/default.pa:

load-module module-remap-sink sink_name=speakers remix=no
master=alsa_output.pci-0000_00_1b.0.analog-surround-51 channels=2
master_channel_map=front-left,front-right channel_map=front-left,front-right
load-module module-remap-sink sink_name=headphones remix=no
master=alsa_output.pci-0000_00_1b.0.analog-surround-51 channels=2
master_channel_map=rear-left,rear-right   channel_map=front-left,front-right

After restarting my pulseaudio, two new sinks appear. However, those two
sinks won't produce any output on any of my audio ports. The old default
output sink of the soundcard still works, but outputs the same stereo sound
on all ports.

After fiddling around a few hours, I'm pretty sure that the underlying
problem is that my surround sound doesn't work at all with pulseaudio. When
I change my profile to Analog Surround 5.1 Output with pavucontrol, 6
mixers appear on the Output Devices tab. However, of those mixers, only the
two front mixers will change the output volume (for all outputs). Any of
the other mixers won't change anything for any of my output ports. When
trying to play a film with 5.1 sound, all my output ports produce the same
sound. I've also tried the default-sample-channels = 6 option mentioned in
the documentation, to no avail. As far as I understand, this option is now
obsolete due to the introduction of profiles (i.e. Analog Stereo Output,
Analog Surround 5.1 Output etc) anyway.

I'm pretty sure, that the problem lies within pulseaudio, as Alsa seems to
support 5.1 sound for my card: When I use alsamixer (by selecting my
soundcard with F6 instead of the pulse mixers), I can change the volume of
each of my output ports seperately. Additionally, the Alsa test
utility speaker-test -c 6 -t w reports the correct (and different) sound
output for each of my output ports. I believe that somehow pulseaudio
doesn't correctly map to Alsa's mixer channels. I've spend the last day
reading pulseaudio documentation and tried different changes to my profiles
in /usr/share/pulseaudio/alsa-mixer, but nothing seems to work. My surround
mixers keep broken and I don't get any clear error message from pulseaudio.

You pasted a log output of pulseaudio -vvvv at http://pastebin.com/378KjrVT,
where I've started pulseaudio with the two module-remap-sink lines and
tried changing the output sink of one of my output applications to the new
remapped devices. I hope the log is not too verbose; I could also provide
the output of just pulseaudio -v. As you can see from the attached log, my
soundchip is a Realtek ALC892.

Any ideas how I could further debug this? I'm very willing to help any
pulseaudio developer to track down this problem (maybe bug?).

Thanks for your help!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20150104/28a112bf/attachment.html>

More information about the pulseaudio-discuss mailing list