[pulseaudio-discuss] module-remap-sink not working for surround card

Tanu Kaskinen tanu.kaskinen at linux.intel.com
Fri Jan 9 03:59:57 PST 2015

On Sun, 2015-01-04 at 20:54 +0100, Martin Klein wrote:
> Hi,
> I want to split the different outputs ports of my surround card to
> different sinks. For this, I'm trying to use module-remap-sink with
> the following lines in my /etc/pulse/default.pa:
> load-module module-remap-sink sink_name=speakers remix=no
> master=alsa_output.pci-0000_00_1b.0.analog-surround-51 channels=2
> master_channel_map=front-left,front-right
> channel_map=front-left,front-right
> load-module module-remap-sink sink_name=headphones remix=no
> master=alsa_output.pci-0000_00_1b.0.analog-surround-51 channels=2
> master_channel_map=rear-left,rear-right
> channel_map=front-left,front-right
> After restarting my pulseaudio, two new sinks appear. However, those
> two sinks won't produce any output on any of my audio ports. The old
> default output sink of the soundcard still works, but outputs the same
> stereo sound on all ports.
> After fiddling around a few hours, I'm pretty sure that the underlying
> problem is that my surround sound doesn't work at all with pulseaudio.
> When I change my profile to Analog Surround 5.1 Output with
> pavucontrol, 6 mixers appear on the Output Devices tab. However, of
> those mixers, only the two front mixers will change the output volume
> (for all outputs). Any of the other mixers won't change anything for
> any of my output ports. When trying to play a film with 5.1 sound, all
> my output ports produce the same sound. I've also tried the
> default-sample-channels = 6 option mentioned in the documentation, to
> no avail. As far as I understand, this option is now obsolete due to
> the introduction of profiles (i.e. Analog Stereo Output, Analog
> Surround 5.1 Output etc) anyway.
> I'm pretty sure, that the problem lies within pulseaudio, as Alsa
> seems to support 5.1 sound for my card: When I use alsamixer (by
> selecting my soundcard with F6 instead of the pulse mixers), I can
> change the volume of each of my output ports seperately. Additionally,
> the Alsa test utility speaker-test -c 6 -t w reports the correct (and
> different) sound output for each of my output ports. I believe that
> somehow pulseaudio doesn't correctly map to Alsa's mixer channels.
> I've spend the last day reading pulseaudio documentation and tried
> different changes to my profiles in /usr/share/pulseaudio/alsa-mixer,
> but nothing seems to work. My surround mixers keep broken and I don't
> get any clear error message from pulseaudio.

It sounds like the surround51 alsa device isn't working as it should.
What if you try "speaker-test -D surround51:0 -c 6 -t wav"? Does it work
as expected?


More information about the pulseaudio-discuss mailing list