[pulseaudio-discuss] Service fails on systemctl start. Status always "activating"

Karl Stahl karl at soundhound.com
Mon May 22 18:21:24 UTC 2017

Thanks for the reply!  I'm running Raspbian and have pulseaudio version 5.0.
I tried changing it to type=simple, and that fixed the notify issue, but it's still not working.  This is what I get:

$ paplay test.wav
connect localhost port 6020: Connection refused
xcb_connection_has_error() returned true
Connection failure: Connection refused
pa_context_connect() failed: Connection refused

> On May 22, 2017, at 10:58 AM, Tanu Kaskinen <tanuk at iki.fi> wrote:
> On Mon, 2017-05-22 at 09:03 -0700, Karl Stahl wrote:
>> I'm trying to get pulseaudio running on a Raspberry Pi 3 (ARM).  I'm
>> having trouble getting the service to start properly.  The status
>> always says "activating", but never seems to finish.  Any ideas?
> What's the pulseaudio version? Raspbian ships 5.0, and if you have
> that, then pulseaudio doesn't notify systemd when it has started.
> Systemd expects that notification, since you set type=notify in the
> service file. You can try type=simple instead.
> -- 
> Tanu
> https://www.patreon.com/tanuk
> _______________________________________________
> pulseaudio-discuss mailing list
> pulseaudio-discuss at lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/pulseaudio-discuss

More information about the pulseaudio-discuss mailing list