[pulseaudio-discuss] Service fails on systemctl start. Status always "activating"

Tanu Kaskinen tanuk at iki.fi
Mon May 22 19:08:28 UTC 2017

On Mon, 2017-05-22 at 11:21 -0700, Karl Stahl wrote:
> Thanks for the reply!  I'm running RaspbianĀ and have pulseaudio
> version 5.0.
> I tried changing it to type=simple, and that fixed the notify issue,
> but it's still not working.  This is what I get:
> $ paplay test.wav
> connect localhost port 6020: Connection refused
> xcb_connection_has_error() returned true

These are unfamiliar errors to me... Is your X11 setup unusual? The
first error could be about libpulse trying to connect to X11 using port
6020, which would be strange, because normally X11 uses unix sockets.

> Connection failure: Connection refused
> pa_context_connect() failed: Connection refused

Is pulseaudio running? If it is, paplay doesn't find the socket. That
might be because systemd sets the XDG_RUNTIME_DIR environment variable
for the services it starts, and that affects the socket location, but
your login environment might not have that variable set. Try setting
XDG_RUNTIME_DIR=/run/user/1000 in your login session setup.

If that doesn't help, run "PULSE_LOG=99 pactl info". That will show
what socket pactl tries to use. You can compare that to the output of
"netstat -lx | grep pulse", that will show what socket the server uses.



More information about the pulseaudio-discuss mailing list