[pulseaudio-discuss] front-panel headphones not working with Intel PCH and Realtek ALC892 [solved]

Peter F. Patel-Schneider pfpschneider at gmail.com
Sat Dec 15 15:48:25 UTC 2018

Well, if not really solved at least I patched the problem, which is not really
about pulseaudio at all.

The Realtek ALC892 has a pin group that is by default a second line-in but can
be switched to be an output pin.  So there are four inputs by default, two
mic-level inputs and two line-level inputs.

Desktop motherboards don't generally have two line-level inputs.  Instead they
may have one line-level input on the back-panel I/O.   What they also have is
an HD audio header that almost always ends up being connected to two 3.5mm
jacks on the case.  One of the jacks is for a microphone and one is for

My motherboard attaches the front mic pin and the second line-in pin from the
chip to this header.  Windows knows enough (probably by means of a quirk for
the motherboard) to repurpose the second line-in as a headphone jack.
However, this is not done in Linux.

I found out much of this from
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/993162 which is about a
different motherboard but the same chip and the same pin attachment.  I don't
know whether it is worthwhile to have a quirk added for my (old) motherboard.

So what I did was to use hdajackretask to retask pin 0x1b to Headphone, and
install a boot override for this.  I think that a reboot is needed to have the
change take total effect.


On 12/14/18 12:33 PM, Russell Treleaven wrote:
> take 2
> `aplay -l` for the playback devices and `arecord -l` for the capture devices.
> Sometimes disabling auto-mute at the alsa layer makes the headphone jack show up.
> On Fri, Dec 14, 2018 at 11:14 AM Russell Treleaven <rtreleaven at bunnykick.ca
> <mailto:rtreleaven at bunnykick.ca>> wrote:
>     First thing is to do is verify that alsa sees the card.
>     `aplay -l` for playback devices and `aplay -L` for capture devices.
>     If alsa doesn't see it pulseaudio won't see it.
>     On Fri, Dec 14, 2018 at 10:56 AM Peter F. Patel-Schneider
>     <pfpschneider at gmail.com <mailto:pfpschneider at gmail.com>> wrote:
>         Hi:
>         I have an Intel 7 Series desktop where the audio chip is a Realtek ALC892.
>         The audio setup is quite normal, with 7+1+mic on the rear and mic and
>         headphones on the front.
>         However, pulseaudio doesn't show a headphone port for the card (HDA Intel
>         PCH), just front and rear mics, digital output, HDMI 0 and 1, output
>         lineout
>         (which I assume is the 7+1 on the back), and input linein.
>         I looked around and found a few related documents but nothing that
>         appears to
>         be about this particular problem.  Does anyone know what is wrong? 
>         How can I
>         fiddle with the description of the card?
>         Thanks,
>         peter
>         _______________________________________________
>         pulseaudio-discuss mailing list
>         pulseaudio-discuss at lists.freedesktop.org
>         <mailto:pulseaudio-discuss at lists.freedesktop.org>
>         https://lists.freedesktop.org/mailman/listinfo/pulseaudio-discuss
>     -- 
>     Sincerely,
>     Russell Treleaven
>     sip:rtreleaven at sip.bunnykick.ca
>     <mailto:sip%3Artreleaven at sip.bunnykick.ca>;transport=tcp
> -- 
> Sincerely,
> Russell Treleaven
> sip:rtreleaven at sip.bunnykick.ca
> <mailto:sip%3Artreleaven at sip.bunnykick.ca>;transport=tcp
> _______________________________________________
> pulseaudio-discuss mailing list
> pulseaudio-discuss at lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/pulseaudio-discuss

More information about the pulseaudio-discuss mailing list