[pulseaudio-discuss] Pulseaudio Bluez literally

liebrecht at grossmann-venter.com liebrecht at grossmann-venter.com
Mon Dec 24 08:44:37 UTC 2018

To add,  I attempted to remove the entire soundsystem and reinstall it.

I removed jackd
apt-get remove jackd

Then I purged pulseaudio  as it tends to have corrupt configs.

apt-get purge pulseaudio
*This removes pulseaudio-module-bluetooth & pulseaudio-module-jack

apt-get install pulseaudio
apt-get install pulseaudio-module-bluetooth
killall pulseaudio

Then it works and you can see sound played on the Tab after switching on 
the audio
in Tab bluetooth

So the problem seems to be squarely with pulseaudio-module-jack.

So I install pulseaudio-module-jack again by
apt-get install pulseaudio-module-jack
killall pulseaudio

and immediately the bluetooth monitor "blueman manager" switches off all 
the redbluegreen indicators and I have the same problem.

I switch on sound in the tab in bluetooth section, then the icons appear 
again and sound is received by pulseaudio.

However there is no routing of the sound to Jack. Nowhere do I see in 
the outputs of the pulsaudio mixer any option to select jack as the 
output device or any of my hardware devices.

I then rebooted,  and when it caqme up everything still worked.
I then installed
apt-get install jackd
apt-get install qjackctl

then started jack through qjackctl
Now it fails where previously it worked great.
I get the following output from qjackctl

Cannot initialize driver
JackServer::Open failed with -1
Failed to open server
03:38:06.042 JACK was stopped
03:38:06.043 Post-shutdown script...
03:38:06.043 /usr/bin/pajackconnect reset &
cat: /tmp/pasinkj: No such file or directory
cat: /tmp/pasourcej: No such file or directory
03:38:06.447 Post-shutdown script terminated successfully.
You need to specify a sink either by its name or its index.
You need to specify a source either by its name or its index.
03:38:07.425 Could not connect to JACK server as client. - Overall 
operation failed. - Unable to connect to server. Please check the 
messages window for more info.
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, 
skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, 
skipping unlock

That is where I am now stuck. I am not sure if this is now a jack 
problem or a pulseaudio problem. Please advise and I will post on the 
relevant usergroup.


More information about the pulseaudio-discuss mailing list