[Spice-devel] [PATCH spice-gtk] channel: rely on couroutine instead of channel state
marcandre.lureau at gmail.com
Sun Dec 2 06:24:07 PST 2012
On Sun, Dec 2, 2012 at 12:35 PM, Hans de Goede <hdegoede at redhat.com> wrote:
> Sounds like a nice cleanup to me. Or maybe further
> split the recv_ functions into a recv_ and send_next_bit
> parts and then have a channel_handle_link()
> calling all the send_ and recv_ parts? I think that might
Yeah, but as a first step I would prefer to keep just that mechanical
patch, and do further clean-up later on.
end up more readable then a single large function and
> the compiler should inline it all anyways (since it is all
> called from only 1 place).
I don't think the readibility and modularity will change that much if it's
a single function or multiple recv and send functions. Those functions are
not reused and the process can't be more linear. Having a single function
make it easier to share variables/state (no need to pass values/state). But
anyway, that should be a different patch that we will discuss.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Spice-devel