[Spice-devel] [PATCH 00/14] Minor improvements and coding style changes to the streaming agent

Christophe de Dinechin christophe at dinechin.org
Wed Feb 14 17:52:08 UTC 2018


From: Christophe de Dinechin <dinechin at redhat.com>

This series implements a number of comments that were made during
previous code reviews, including a reworked / udpated version of the
stream RAII patch.

Christophe de Dinechin (14):
  Add required <string> header
  Capture 'cursor' by value
  streaming_requested is really a bool
  Add PRIu64 format for uint64_t
  Rename 'quit' to 'quit_requested' for consistency with
    'streaming_requested'
  log_binary is really a boolean
  Do not create std::string for constants
  Use RAII to cleanup stream in case of exception or return
  Remove clang warning on marking a function const
  Remove clang warning on missing 'override'
  Replace inefficient C-style initialization with C++-style
  Get rid of C-style memset initializations, use C++ style aggregates
  Use C++ style for cursor message initialization instead of C style
  Do not test twice for the same condition

 src/mjpeg-fallback.cpp        |   4 +-
 src/mjpeg-fallback.hpp        |   2 +-
 src/spice-streaming-agent.cpp | 182 ++++++++++++++++++++++++------------------
 src/static-plugin.hpp         |   2 +-
 4 files changed, 107 insertions(+), 83 deletions(-)

-- 
2.13.5 (Apple Git-94)



More information about the Spice-devel mailing list