[systemd-devel] Fail to reset-failed as user

Olivier Brunel jjk at jjacky.com
Fri Dec 12 07:06:09 PST 2014


Today I had one unit in failed state, and after taking care of things I
wanted to simply reset its state (to inactive) w/out having to start it.

Looking up the man page, I see there's a command reset-failed for this
exact purpose, awesome. So I go:

% systemctl reset-failed backups2.service
Failed to reset failed state of unit backups2.service: No such device or

I was nicely asked to authenticate, but then it failed stating the unit
doesn't exist or something (not sure what the error message refers to)?
Now of course said unit does exist:

% systemctl is-failed backups2.service

And I could eventually do it, as root:

% sudo systemctl reset-failed backups2.service

This worked fine and is probably what I would have done had my fingers
not slipped (sc instead of ssc, aliases for `systemctl` and `sudo
systemctl` resp.), but I'm not sure what I missed: since I was properly
authenticated, shouldn't the systemctl call also have worked?

FYI here's what shows up in the journal, confirming the auth:
Dec 12 15:40:00 arch.local polkitd[670]: Operator of unix-session:c3
successfully authenticated as unix-user:jjacky to gain TEMPORARY
authorization for action org.freedesktop.systemd1.manage-units for
system-bus-name::1.259 [systemctl reset-failed backups2.service] (owned
by unix-user:jjacky)

What am I missing/misunderstanding? (or is this a bug?)

More information about the systemd-devel mailing list