[systemd-devel] systemd-222 mount issues on CentOS 7

Lokesh Mandvekar lsm5 at fedoraproject.org
Wed Oct 5 05:24:45 UTC 2016

On Tue, Oct 04, 2016 at 10:28:25AM +0200, Michal Sekletar wrote:
> On Tue, Sep 27, 2016 at 5:05 PM, Lokesh Mandvekar
> <lsm5 at fedoraproject.org> wrote:
> > Now, I can mount these partitions with:
> >
> > # lvm vgchange -ay
> >
> > but this still doesn't automount succesfully on a reboot.
> >
> > Did I miss something here?
> I'd check from emergency shell whether lvm2-pvscan at .service was run.
> This instantiated systemd service is responsible for scaning LVM PVs
> and auto-activating LVs on them. Note that it is spawned from udev
> rules in case when certain conditions are met, e.g. block device is
> identified as LVM2_member and udev event doesn't have SYSTEMD_READY=0
> property set.

Michal, thanks for the reply.

What's the correct way to check if lvm2-pvscan at .service was run?

I tried:

# systemctl status lvm2-pvscan at .service
Failed to get properties: Unit name lvm2-pvscan at .service is not valid.

> Also, there has been couple of bugfixes since systemd-222 that are
> maybe related. We backported them to RHEL/CentOS 7 (systemd-219).

Could you please link me to these patches if that's doable?
I see the rpm source contains tons of patches.

Freenode: lsm5
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 801 bytes
Desc: not available
URL: <https://lists.freedesktop.org/archives/systemd-devel/attachments/20161005/69534c5d/attachment.sig>

More information about the systemd-devel mailing list