[systemd-devel] systemd-222 mount issues on CentOS 7

Andrei Borzenkov arvidjaar at gmail.com
Wed Oct 5 06:38:18 UTC 2016

On Wed, Oct 5, 2016 at 8:24 AM, Lokesh Mandvekar <lsm5 at fedoraproject.org> wrote:
> On Tue, Oct 04, 2016 at 10:28:25AM +0200, Michal Sekletar wrote:
>> On Tue, Sep 27, 2016 at 5:05 PM, Lokesh Mandvekar
>> <lsm5 at fedoraproject.org> wrote:
>> > Now, I can mount these partitions with:
>> >
>> > # lvm vgchange -ay
>> >
>> > but this still doesn't automount succesfully on a reboot.
>> >
>> > Did I miss something here?
>> I'd check from emergency shell whether lvm2-pvscan at .service was run.
>> This instantiated systemd service is responsible for scaning LVM PVs
>> and auto-activating LVs on them. Note that it is spawned from udev
>> rules in case when certain conditions are met, e.g. block device is
>> identified as LVM2_member and udev event doesn't have SYSTEMD_READY=0
>> property set.
> Michal, thanks for the reply.
> What's the correct way to check if lvm2-pvscan at .service was run?
> I tried:
> # systemctl status lvm2-pvscan at .service
> Failed to get properties: Unit name lvm2-pvscan at .service is not valid.

You need to look for instances of template, not for template itself.
Unfortunately, the only way to do it is really

systemctl --all | grep lvm2-pvscan

and then check each individual service.

Extending systemctl to automatically handle (at least, for display
purposes) template instances may be useful.

More information about the systemd-devel mailing list