[systemd-devel] How to unset "uaccess" tag in udev rule?

David Herrmann dh.herrmann at gmail.com
Mon Mar 27 12:13:30 UTC 2017


On Sun, Mar 26, 2017 at 8:07 PM, Manuel Reimer
<Manuel.Spam at nurfuerspam.de> wrote:
> On 03/25/2017 05:16 PM, David Herrmann wrote:
>>>> So far I did this by creating an empty file with the same name in
>>>> /etc/udev/rules.d which works well, but for no reason the name was
>>>> changed some time ago which overrides my empty file and reactivates
>>>> the problematic rule.
>>> That's the only way. Tags cannot be unset.
>> Use TAG-="foobar".
> I've tried that and it doesn't work.

The `-=' operator was introduced for exactly this use-case (which the
commit I quoted should explain). If it does not work, it has to be
fixed. Last time I checked, it worked.

Hence, if you need help using it, please give us as much information
as possible. Please verify the operator works with something that is
not already used (set some random TAG and remove it again, check with
`udevadm` whether it works).

If you have no clue how to debug it yourself, please specify _what_
you changed, what systemd version / distro / etc., you're running, so
we can reproduce it and help you further.


More information about the systemd-devel mailing list