[Bug 27865] Port more channel implementations to GabbleBaseChannel
bugzilla-daemon at freedesktop.org
bugzilla-daemon at freedesktop.org
Wed Apr 28 12:52:10 CEST 2010
https://bugs.freedesktop.org/show_bug.cgi?id=27865
Simon McVittie <simon.mcvittie at collabora.co.uk> changed:
What |Removed |Added
----------------------------------------------------------------------------
Status|NEW |ASSIGNED
Status Whiteboard| |review-, minor changes
AssignedTo|telepathy-bugs at lists.freede |will.thompson at collabora.co.
|sktop.org |uk
--- Comment #1 from Simon McVittie <simon.mcvittie at collabora.co.uk> 2010-04-28 03:52:09 PDT ---
> + presence = gabble_presence_cache_get (self->parent.conn->presence_cache,
> + self->parent.target);
We generally avoid relying on the @parent member of instance structs like this,
since it breaks if you change the inheritance hierarchy to include an extra
intermediate class, which is meant to be something that's always safe in OO.
I'd be inclined to use:
GabbleBaseChannel *base = (GabbleBaseChannel *) self;
presence = gabble_presence_cache_get (base->conn->presence_cache,
base->target);
(Or you could call it @chan instead of @base, or something.)
> @@ -462,23 +234,23 @@ gabble_im_channel_dispose (GObject *object)
> + self->parent.conn->roster, base->target);
Er, this mixes both modes in consecutive arguments :-)
Other than that, review+.
--
Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.
More information about the telepathy-bugs
mailing list