[Telepathy] need some help to get installed from the source
callkalpa at gmail.com
Thu Jan 13 23:49:20 PST 2011
On Fri, Jan 14, 2011 at 4:16 AM, Danielle Madeley
<danielle.madeley at collabora.co.uk> wrote:
> You may find the jhbuild tool useful for building Empathy and its
> dependencies from source.
Thanks. This app seems really cool. Still it couldn't get the source compiled.
/usr/bin/ld: register.o: undefined reference to symbol 'gpg_strerror'
/usr/bin/ld: note: 'gpg_strerror' is defined in DSO
/home/kalpa/devel/gnome/lib/libgpg-error.so.0 so try adding it to the
linker command line
/home/kalpa/devel/gnome/lib/libgpg-error.so.0: could not read symbols:
collect2: ld returned 1 exit status
make: *** [register] Error 1
make: Leaving directory `/home/kalpa/checkout/gnome/libgcrypt-1.4.5/tests'
make: *** [all-recursive] Error 1
make: Leaving directory `/home/kalpa/checkout/gnome/libgcrypt-1.4.5'
make: *** [all] Error 2
*** Error during phase build of libgcrypt: ########## Error running
make *** [5/72]
 Rerun phase build
I get this error message.
> On Thu, 2011-01-13 at 10:31 +0530, Kalpa Welivitigoda wrote:
>> On Thu, Jan 13, 2011 at 2:09 AM, Nicolas Dufresne
>> <nicolas.dufresne at collabora.co.uk> wrote:
>> > Le mercredi 12 janvier 2011 à 23:00 +0530, Kalpa Welivitigoda a écrit :
>> > Hi,
>> > I want to get empathy installed from the source. I'm on Fedora 14.
>> > When I ./configure I get the following error,
>> > Requested 'folks >= 0.3.3' but version of Folks is 0.1.16
>> > Requested 'folks-telepathy >= 0.3.3' but version of Folks Telepathy
>> > support library is 0.1.16
>> > Requested 'gio-2.0 >= 2.27.2' but version of GIO is 2.26.0
>> > Requested 'gio-unix-2.0 >= 2.27.2' but version of GIO unix specific
>> > APIs is 2.26.0
>> > No package 'gsettings-desktop-schemas' found
>> > No package 'telepathy-farsight' found
>> > Requested 'telepathy-glib >= 0.13.9' but version of Telepathy-GLib is
>> > 0.11.16
>> > Requested 'gtk+-3.0 >= 2.99.0' but version of GTK+ is 2.90.5
>> > Requested 'libnotify >= 0.7.0' but version of libnotify is 0.5.1
>> > No package 'gcr-3' found
>> > I tried to install folks 0.3.3 from source and it needs
>> > telepathy-glib. telepathy-glib was installed from source. still I get
>> > the above error. Any help is highly appreciated.
>> > You probably forgot to set PKG_CONFIG_PATH and LD_LIBRARY_PATH to where you
>> > installed your custom build ?
>> > export PKG_CONFIG_PATH=libpath/pkgconfig
>> > export LD_LIBRARY_PATH=libpath
>> Thanks for the help. I installed folks successfully. But couldn't
>> install empathy yet. Now it says,
>> Requested 'gtk+-3.0 >= 2.99.0' but version of GTK+ is 2.90.5
>> Requested 'libnotify >= 0.7.0' but version of libnotify is 0.5.1
>> No package 'gcr-3' found
>> When I try to make gtk it says
>> /usr/share/gir-1.0/Atk-1.0.gir: Incompatible version 1.1 (supported: 1.2)
>> make: *** [Gtk-3.0.gir] Error 1
>> and I couldn't find from where to install this version of Atk
>> I couldn't find where to get libnotify 0.7 and what package contains gcr-3
>> Any help is highly appreciated.
> Danielle Madeley
> Software Developer, Collabora Ltd. Melbourne, Australia
Kalpa Pathum Welivitigoda
More information about the telepathy