[Uim] Replacing property handling codes with property.scm
tkng at xem.jp
Fri Oct 29 23:38:34 EEST 2004
On Fri, 29 Oct 2004 03:51:23 +0900
YamaKen <yamaken at bp.iij4u.or.jp> wrote:
> At Mon, 25 Oct 2004 03:29:21 +0900,
> yamaken at bp.iij4u.or.jp wrote:
> > At Mon, 25 Oct 2004 03:15:34 +0900,
> > tkng at xem.jp wrote:
> > >
> > > On Sat, 23 Oct 2004 17:44:12 +0900
> > > YamaKen <yamaken at bp.iij4u.or.jp> wrote:
> > > > What I meant by the word 'manipulator' is an unit of user
> > > > interface entity. The unit which has an unique ID is required to
> > > > implement the framework, to contorl user preference.
> > > > I think that the names 'entity' or 'unit' are too generic to
> > > > indicate the role, so I suggest the name 'manipulator'. Do you
> > > > have a good idea? Is the name 'ui-unit' is meaningful for you?
> > >
> > > ui-unit is easier than manipulator for me.
> > Okay. It's the most preferable candidate for now. Propose
> > better name if you have found.
> I would like to use the word 'widget' instead of 'ui-unit'. How
> do you feel it?
ui-unit is better for me. widget will be confusing.
More information about the uim