[Uim] gtk-2.6.1:

Gábor Farkas gabor at z10n.net
Tue Feb 1 23:19:18 EET 2005


uim-0.4.5 here.

after i upgraded to gtk-2.6.x (2.6.1), i'm getting this message when 
using gtk programs:

failed in listen(): Invalid argument.

i tracked it back, and it's uim's problem.

if i remove uim from my computer, the problem vanishes.
if i put it back, the problem is also back ;)

the problem seems to be gtk-2.6..

because i compiled gtk-2.4 into a separate directory,
and used LD_LIBRARY_PATH to have the gtk program(s) use those files, and 
   in that case, no warnings..

the input method still works fine, except one problem:
i witnessed this with eclipse:
he showed me that "failed-in-listen-and-so-on" warning on the console 
looooots of times.

and after some time, he reported (also on the console):
"fail to create socket: Too many open files".

and from this point on, eclipse is dead.

i assume the same would happen with my other gtk programs, if i would 
had them running long enough..

i tried google to search for this, but all i got were old and/or 
japanese mails, which were nearly-inunderstandable fandor me :(

recompiling uim didn't help.
also tried the uim svn snapshot. same problem.

any ideas what went wrong?
gentoo linux here btw.


More information about the uim mailing list