[Wayland-bugs] [Bug 781909] Implement KDE's server-decoration protocol

gtk+ (GNOME Bugzilla) bugzilla at gnome.org
Fri Jul 28 16:34:44 UTC 2017


https://bugzilla.gnome.org/show_bug.cgi?id=781909

Emmanuele Bassi (:ebassi) <ebassi at gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #350696|none                        |reviewed
             status|                            |

--- Comment #2 from Emmanuele Bassi (:ebassi) <ebassi at gmail.com> ---
Review of attachment 350696:

Hi; thanks for the patch — and I apologise for taking this long to get a
review.

In general, this looks okay to me, and fits in with the GTK approach.

::: gdk/wayland/gdkdisplay-wayland.c
@@ +336,3 @@
 static void
+server_decoration_manager_default_mode(void                          *data,
+                       struct org_kde_kwin_server_decoration_manager *manager,

Coding style:

 1. missing space between function name and open parenthesis
 2. the argument types should be aligned

@@ +340,3 @@
+{
+  GdkWaylandDisplay *display_wayland = data;
+  g_warning("Compositor prefers decoration mode %d", mode);

This should be a g_debug(), and it would be nice to translate the mode from
integer to string, according to the protocol.

@@ +479,3 @@
+        wl_registry_bind (display_wayland->wl_registry, id,
+                          &org_kde_kwin_server_decoration_manager_interface,
1);
+     
org_kde_kwin_server_decoration_manager_add_listener(display_wayland->server_decoration_manager,

Coding style: missing space between function name and open parenthesis.

::: gdk/wayland/gdkwaylanddisplay.h
@@ +59,3 @@

+gboolean
+gdk_wayland_display_prefers_ssd                                 (GdkDisplay
*display);

Coding style: the name of the function should be on the same line as the return
type.

::: gdk/wayland/gdkwaylandwindow.h
@@ +82,3 @@
                                                                         char  
   *parent_handle_str);

+void gdk_wayland_window_enable_csd                              (GdkWindow
*window);

I think this is a bit of a misnomer; we're not really enabling CSD per se — we
are telling the compositor that we are using client-side decorations.

I don't have a better name to propose, though.

-- 
You are receiving this mail because:
You are on the CC list for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/wayland-bugs/attachments/20170728/6d2fcc2d/attachment.html>


More information about the wayland-bugs mailing list