Using the Wayland port of QT

Benjamin Franzke benjaminfranzke at
Sun Nov 21 09:39:02 PST 2010

$FILESDIR is a gentoo specific vairable inside ebuild, which points to
ebuild-pwd/files (doesnt matter for you..)
however this patch is located there in the repo:;a=blob;f=x11-libs/qt-wayland/files/config-test-wayland.patch

I've also created a merge request for that stuff now, so you could
also use that:

After you have patched and compiled again you should install qt.
the wayland platform isnt found if you run from within the builddir
without installing

list of the basic instructions again here:
  patch .....
  ./configure -prefix $HOME/your_prefix -qpa -opengl es2
  make install
  export LD_LIBRARY_PATH=$HOME/your_prefix/lib
  examples/widgets/analogclock/analogclock -platform wayland

2010/11/21 nerdopolis <bluescreen_avenger at>:
> I'm having a bit of trouble trying to decypher the ebuild file I think I must
> be missing somthing from there...
> I ran configure with the  -qpa -opengl es2 options
> But whenever I try tohen ever I try to run a QT app I get:
> Failed to load platform plugin "wayland". Available platforms are:
> Aborted
> -platform does not seem to be in the standard QT libraries, but it is in
> these, so I think I must be close.
> I see a line in there that says EGIT_PATCHES=( "${FILESDIR}/config-test-
> wayland.patch" ) . I don't think I can see that file, or know where the
> $FILESDIR variable is being defined. I don't know if this has anything to do
> with the missing plugin...
> I think I am using the correct repo: when I run 'git branch' in the folder I
> get:
>  4.7
> * lighthouse-wayland
> _______________________________________________
> wayland-devel mailing list
> wayland-devel at

More information about the wayland-devel mailing list