[WIP] xwayland fix

darxus at chaosreigns.com darxus at chaosreigns.com
Tue Apr 3 21:09:06 PDT 2012

Thanks for working on this.  I tried it, with all 6 of your patches
applied, with xf86-video-wlshm and got

/home/darxus/install/bin/Xorg: symbol lookup error: /home/darxus/install/lib/xorg/modules/extensions/libxwayland.so: undefined symbol: wl_shm_create_buffer

That was with wayland commit aa777e5b10e17d12c4bb6440f7c659d2a12191f5

I went back to weston:
919fbf0 cairo-util: Use nearest filtering for rendering frame
and wayland:
68cf7a1 wayland-utils: add wl_list_for_each_reverse_safe macro.

To revert the changes in shm handling.

Then everything built and ran, but still no output.  Just as before.
Is xf86-video-wlshm even expected to work at this point?

xserver-launcher is built into weston, and not something that's supposed to
build a separate binary, run manually, right?

"When you think of the long and gloomy history of man, you will find
more hideous crimes have been committed in the name of obedience than
have ever been committed in the name of rebellion." - C. P. Snow

More information about the wayland-devel mailing list