How do I run Wayland outside of X?

Bill Spitzak spitzak at
Mon Apr 9 08:17:34 PDT 2012

I'm having great success running the test x11_compositor even on my 
primitive machine now. The previous requirement that EGL_DEPTH_SIZE be 
turned off seems to be fixed now (though it would be nice to have an EGL 
program that actually uses the depth buffer to see if this works, that 
may be something to work on).

Wayland/weston are installed without the setuid bit in ~/install/...

I am able to launch weston under X with a script that sets the 
environment to look there before running it. I can then run clients by 
typing them into the weston-terminal I can launch from there, or by 
running from outside using a similar script to set the environment.

However I cannot run it outside of X. Perhaps I just need some 
instructions on how to do so.

The best result I have had was by altering weston to chown root.root and 
to turn on the setuid bit, and then running from a pty I switch to with 
Ctrl+Alt+1. In this case it certainly takes over the screen and displays 
a hash of colors and lines that seem to be the same colors as the X 
display. However nothing works and I cannot get out of it except by 
rebooting. Previous versions of wayland I could get out of by typing 
Ctrl+Alt+8 to get back to X, then Ctrl+Alt+1 to get the pty again, and 
then ^C, but now nothing works.

I think perhaps I need to turn off X but I'm not sure how you do that! 
If I don't have to turn off X, can I run it by just clearing $DISPLAY 
before running it?

I tried variations on setting suid on other programs but none of that 
makes any difference.

There is also weston-launch in the newest git repository, but all I get is:

weston-launch: Permission denied. You should..
  - enable systemd session support for weston-launch.
  - add yourself to the 'weston-launch' group.

I have no idea how to do this.

More information about the wayland-devel mailing list