How do I run Wayland outside of X?

Scott Moreau oreaus at
Mon Apr 9 08:49:08 PDT 2012

> Wayland/weston are installed without the setuid bit in ~/install/...
> I am able to launch weston under X with a script that sets the environment
> to look there before running it. I can then run clients by typing them into
> the weston-terminal I can launch from there, or by running from outside
> using a similar script to set the environment.
> However I cannot run it outside of X. Perhaps I just need some
> instructions on how to do so.
> The best result I have had was by altering weston to chown root.root and
> to turn on the setuid bit, and then running from a pty I switch to with
> Ctrl+Alt+1. In this case it certainly takes over the screen and displays a
> hash of colors and lines that seem to be the same colors as the X display.
> However nothing works and I cannot get out of it except by rebooting.
> Previous versions of wayland I could get out of by typing Ctrl+Alt+8 to get
> back to X, then Ctrl+Alt+1 to get the pty again, and then ^C, but now
> nothing works.
> I think perhaps I need to turn off X but I'm not sure how you do that! If
> I don't have to turn off X, can I run it by just clearing $DISPLAY before
> running it?

You shouldn't have to stop X or change permissions on the weston binary. It
should be enough to run src/weston from the weston source directory with
escalated permissions, outside of X (in a tty).

> I tried variations on setting suid on other programs but none of that
> makes any difference.
> There is also weston-launch in the newest git repository, but all I get is:
> weston-launch: Permission denied. You should..
>  - enable systemd session support for weston-launch.
>  - add yourself to the 'weston-launch' group.
> I have no idea how to do this.

I wouldn't worry much about this right now since you're using ubuntu and
ubuntu currently does not support systemd. (See for more information). Weston should work
fine in drm but it sounds like your graphics drivers are broken.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the wayland-devel mailing list