GTK Ubuntu Precise packaging success

Rune Kjær Svendsen runesvend at
Thu Apr 19 12:48:14 PDT 2012

Oooook. Figured out a couple of things:

1. The aforementioned system-wide setting allegedly turning off fancy
scrollbars doesn't work
2. When setuid is enabled for /usr/bin/weston it apparently can't read the
file it creates in /tmp

So it's working now when I turn off setuid. In a window running inside
Unity that is.

I can get it to start in a VT when setuid is set, but then launching apps
doesn't work. I get "Error opening file for reading: Permission denied"
(right after listing the path of the socket).
If I turn off the setuid the mouse doesn't work when I start weston in a
VT, and it makes unity crash as well. Is this expected behaviour? Not the
crashing obviously, but that weston can't read the sockets it creates when
setuid is on (and it's running as a normal user)?
I can get it to run properly in a VT by first running "sudo bash" and thus
making it run as root. But I presume this isn't the way it's supposed to
run? Does look mighty smooth though! So silky smooth.
gnome-terminal, gedit and rhythmbox don't work though. Not sure why.
Nothing interested is printed in the VT for me to see after I kill weston.

2012/4/19 <darxus at>

> On 04/19, Rune Kjær Svendsen wrote:
> >    Thanks for the tip. I originally added the line to the file
> >    /etc/skel/.bashrc which is what the .bashrc file in the /home/ubuntu
> >    directory is created from on the live CD. So the line is present in
> >    ~/.bashrc as soon as .bashrc is present in the /home/ubuntu folder on
> the
> >    live CD.
> >
> >    I just tried adding it to
> /etc/X11/Xsession.d/99disable-overlay-scrollbars
> >    instead, which should apply the setting system-wide (as described
> here:
> >    [1]
> >    When I echo the value in a terminal it correctly says 0. Now, however,
> >    when I try to run an application, I get the following error (no matter
> >    which app I run):
> >
> >    �� (gnome-calculator:4443): Gtk-WARNING **: cannot open display: :0.0
> >    �� [1]+� Exit 1����������������� gnome-calculator
> >
> >    Any ideas?
> That's the error you get when XDG_RUNTIME_DIR isn't set, and possibly when
> you don't have write access to it.
> --
> "You may be recognized soon. Hide."
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the wayland-devel mailing list