XWayland is working again

darxus at chaosreigns.com darxus at chaosreigns.com
Tue Apr 24 20:24:07 PDT 2012

On 04/23, darxus at chaosreigns.com wrote:
> I haven't gotten it to work, but krh says it works for him on Intel.

I got it to work.  Some.  With both the Radeon and wlshm DDXes.

Biggest thing was adding the --xserver argument to weston.

Build instructions in my last email were correct.

To use wlshm you need to create $WLD/etc/X11/xorg.conf containing:

Section "Device"
        Identifier "Device"
        Driver "wlshm" # or wlshm or intel

And the Radeon DDX only worked outside of X, which may be related to an
"Unable to retrieve master" error.

Weston really does listen on the X socket and spawn X.org when it gets a
connection.  The X display numbers are automatically incremented, and
$DISPLAY is set appropriately, at least in weston-terminal.

This is some of my first playing with master, so I tried out
weston-launch, without success.  I added myself to the weston-launch group
as suggested, but then I kept getting write access errors - tty0, then
"tty", which strace turned up was /dev/tty8 (that error message could be
improved), then after fixing those by just making them writable by
everybody /dev/dri/card0, and I gave up and just made weston suid root

"It is the first responsibility of every citizen to question authority."
- Benjamin Franklin

More information about the wayland-devel mailing list