Mesa and nouveau and virtualbox?

nerdopolis bluescreen_avenger at
Sun Jan 29 13:14:01 PST 2012


I am working on a Wayland live cd, and it seems one of my testers is having 
some issues with running Wayland on his nvidia card. The weston-compositor is 
displaying a window, but the contents of the weston window are garbled, and 
weston-desktop-shell is failing to start.

I also am having issues on virtualbox with mesa, where the weston window is a 
blank screen. None of the included wayland clients start (including weston-
desktop-shell) but I am able to start a wayland qt application from my live 
disk no problem in virtualbox. I tried getting him to run a qt app on his 
nvidia box, but he got another error, that I am not sure how he got it in the 
first place.

It works great in running bare on my intel GPU.

Do I need that kernel patch on the how to? One of the links is failing, and 
the Live CD uses kernel 3.2... 

Am I missing something in Mesa? I tried messing with some EGL variables, with 
failures, and some segfaults.

These are the options I am passing to build Mesa:

./ --prefix=$WLD --enable-gles2  --with-gallium-
drivers=nouveau,svga,swrast  --with-egl-platforms=x11,wayland,drm --enable-gbm 
--enable-shared-glapi --libdir=$WLD/lib/$(dpkg-architecture -

($(dpkg-architecture -qDEB_HOST_MULTIARCH) is for Ubuntu's multiarch)

Any help will be appreciated. 


More information about the wayland-devel mailing list