Mesa and nouveau and virtualbox?

Joakim Sindholt opensource at
Sun Jan 29 14:43:34 PST 2012

On Sun, 2012-01-29 at 16:14 -0500, nerdopolis wrote:
> Hi. 
> I am working on a Wayland live cd, and it seems one of my testers is having 
> some issues with running Wayland on his nvidia card. The weston-compositor is 
> displaying a window, but the contents of the weston window are garbled, and 
> weston-desktop-shell is failing to start.
> I also am having issues on virtualbox with mesa, where the weston window is a 
> blank screen. None of the included wayland clients start (including weston-
> desktop-shell) but I am able to start a wayland qt application from my live 
> disk no problem in virtualbox. I tried getting him to run a qt app on his 
> nvidia box, but he got another error, that I am not sure how he got it in the 
> first place.
> It works great in running bare on my intel GPU.
> Do I need that kernel patch on the how to? One of the links is failing, and 
> the Live CD uses kernel 3.2... 
> Am I missing something in Mesa? I tried messing with some EGL variables, with 
> failures, and some segfaults.
> These are the options I am passing to build Mesa:
> WLD=/usr/local
> ./ --prefix=$WLD --enable-gles2  --with-gallium-
> drivers=nouveau,svga,swrast  --with-egl-platforms=x11,wayland,drm --enable-gbm 
> --enable-shared-glapi --libdir=$WLD/lib/$(dpkg-architecture -
> ($(dpkg-architecture -qDEB_HOST_MULTIARCH) is for Ubuntu's multiarch)
> Any help will be appreciated. 
> Thanks.

To the best of my knowledge- and please correct me if this is wrong: the
kernel doesn't have the proper facilities to run Wayland without an
actual GPU, and the vbox emulated GPU doesn't have a kms driver, nor
does it have a proper GEM implementation.

More information about the wayland-devel mailing list