Removal of unprefixed container_of()
chad.versace at linux.intel.com
Wed Oct 17 13:50:33 PDT 2012
wayland-util.h defines __wl_container_of() as well as an unprefixed version,
container_of(). The unprefixed version, of course, pollutes the global namespace
and causes symbol collisions in projects that define container_of() slightly
Is there any chance that the unprefixed container_of() macro in wayland-util.h
can be renamed or removed before the 1.0 freeze?
I'll write the patch if the wayland dev's are ok with its removal.
More information about the wayland-devel