Removal of unprefixed container_of()

Kristian Høgsberg krh at
Wed Oct 17 14:05:55 PDT 2012

Hi Chad,

Yeah, we need to kill that.  Thanks for reminding me, looking forward
to the patch :)


On Wed, Oct 17, 2012 at 4:50 PM, Chad Versace
<chad.versace at> wrote:
> wayland-util.h defines __wl_container_of() as well as an unprefixed version,
> container_of(). The unprefixed version, of course, pollutes the global namespace
> and causes symbol collisions in projects that define container_of() slightly
> differently.
> Is there any chance that the unprefixed container_of() macro in wayland-util.h
> can be renamed or removed before the 1.0 freeze?
> I'll write the patch if the wayland dev's are ok with its removal.
> -Chad
> _______________________________________________
> wayland-devel mailing list
> wayland-devel at

More information about the wayland-devel mailing list