Some problems during/after 1st wayland build

Knut Petersen Knut_Petersen at
Sat Sep 1 02:02:49 PDT 2012

Hi everybody!

Some comments / suggestions / bug reports:

1: misses that building weston
will fail without a recent libwebp from

2. misses that after building weston
"make install" needs to be run as root.

3. Weston needs an xcursor theme to be installed and accessible via
~/.icons/default/index.theme, otherwise no cursor will be visible. That
probably also should be mentioned in
as a lot of people don´t have it on their system.

4. After solving problems 1-3, weston and the weston demo clients like gears
worked fine if weston was started as an X client. Without X weston started as
a normal user blocked keyboard and mouse, so a power button reboot or killing
weston via ssh was necessary. Weston without started as root worked fine.

5. I know, (glx)gears is not really a benchmark as fps is limited by vsync. But here on
an idle system fps(~45) stayed 25% below vsync (60).

6. Occasionally short bursts of screen distortions are visible if weston is started
without X.

7. worked fine as a guide to build x client
support, but every X client I tried killed weston:

starting weston

Date: 2012-09-01 CEST
[10:54:46.482] weston 0.95.0
Bug reports to:
Build: 0.95.0-148-ga91291c man: add man page for weston (2012-08-29 15:32:05 -0400)
[10:54:46.483] OS: Linux, 3.6.0-rc3-main+, #7 PREEMPT Sun Aug 26 21:03:24 CEST 2012, i686
[10:54:46.483] Loading module '/home/knut/xorg/WayX/usr/lib/weston/'
[10:54:46.485] initializing x11 backend
[10:54:46.510] EGL version: 1.4 (DRI2)
[10:54:46.510] EGL vendor: Mesa Project
[10:54:46.510] EGL client APIs: OpenGL OpenGL_ES2
[10:54:46.511] EGL extensions: EGL_MESA_drm_image EGL_WL_bind_wayland_display
EGL_KHR_image_base EGL_KHR_image_pixmap EGL_KHR_image
EGL_KHR_gl_renderbuffer_image EGL_KHR_surfaceless_context
EGL_KHR_create_context EGL_NOK_swap_region
EGL_NOK_texture_from_pixmap EGL_NV_post_sub_buffer
[10:54:46.512] GL version: OpenGL ES 2.0 Mesa 9.0-devel (git-2d2f1fd)
[10:54:46.512] GLSL version: OpenGL ES GLSL ES 1.0.16
[10:54:46.513] GL vendor: Intel Open Source Technology Center
[10:54:46.513] GL renderer: Mesa DRI Intel(R) 915GM x86/MMX/SSE2
[10:54:46.513] GL extensions: GL_EXT_blend_minmax GL_EXT_multi_draw_arrays
GL_EXT_texture_compression_dxt1 GL_EXT_texture_format_BGRA8888
GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth24
GL_OES_element_index_uint GL_OES_fbo_render_mipmap
GL_OES_mapbuffer GL_OES_rgb8_rgba8 GL_OES_standard_derivatives
GL_OES_stencil8 GL_OES_texture_3D GL_OES_texture_npot
GL_OES_EGL_image GL_OES_depth_texture
GL_OES_packed_depth_stencil GL_EXT_texture_type_2_10_10_10_REV
GL_APPLE_texture_max_level GL_EXT_read_format_bgra
GL_NV_fbo_color_attachments GL_OES_vertex_array_object
GL_EXT_unpack_subimage GL_NV_draw_buffers GL_NV_read_buffer
[10:54:46.614] x11 output 1024x640, window id 88080391
[10:54:46.614] Loading module '/home/knut/xorg/WayX/usr/lib/weston/'
[10:54:46.615] unlinking stale lock file /tmp/.X1-lock
[10:54:46.616] xserver listening on display :1
[10:54:46.616] Loading module '/home/knut/xorg/WayX/usr/lib/weston/'
[10:54:46.617] launching '/home/knut/xorg/WayX/usr/lib/weston-desktop-shell'
[10:54:46.621] libwayland: using socket /home/knut/tmp/wayland-0

starting any x client from weston terminal
[10:56:29.789] forked X server, pid 30891

X.Org X Server 1.12.2
Release Date: 2012-05-29
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.6.0-rc3-main+ i686
Current Operating System: Linux golem 3.6.0-rc3-main+ #7 PREEMPT Sun Aug 26 21:03:24 CEST 2012 i686
Kernel command line: root=/dev/sdb2 netconsole=6665 at,6666 at acpi_enforce_resources=lax drm.debug=0x0 3
Build Date: 31 August 2012 05:24:11PM

Current version of pixman: 0.27.3
Before reporting problems, check
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/home/knut/xorg/WayX/usr/var/log/Xorg.1.log", Time: Sat Sep 1 10:56:29 2012
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xdnd_atom: 69
wayland_drm_screen_init, device name /dev/dri/card0
opened drm fd: 6
[10:56:30.022] xfixes version: 4.0
[10:56:30.049] caught segv
[10:56:30.050] [000000000804de2a] -- (/home/knut/xorg/WayX/usr/bin/weston)
[10:56:30.050] [00000000b771340c] __kernel_rt_sigreturn ()
[10:56:30.050] [00000000b5da335b] -- (/home/knut/xorg/WayX/usr/lib/weston/
[10:56:30.050] [00000000b5da5303] -- (/home/knut/xorg/WayX/usr/lib/weston/
[10:56:30.051] [00000000b743ebc8] -- (/home/knut/xorg/WayX/usr/lib/
[10:56:30.051] [00000000b7437522] ffi_call_SYSV (/usr/lib/
[10:56:30.051] [00000000b74372be] ffi_call (/usr/lib/
[10:56:30.051] [00000000b7444573] -- (/home/knut/xorg/WayX/usr/lib/
[10:56:30.052] [00000000b743f110] -- (/home/knut/xorg/WayX/usr/lib/
[10:56:30.052] [00000000b7441e4e] -- (/home/knut/xorg/WayX/usr/lib/
[10:56:30.052] [00000000b744268a] wl_event_loop_dispatch (/home/knut/xorg/WayX/usr/lib/
[10:56:30.052] [00000000b7440162] wl_display_run (/home/knut/xorg/WayX/usr/lib/
[10:56:30.053] [000000000804d8cc] -- (/home/knut/xorg/WayX/usr/bin/weston)
[10:56:30.053] [00000000b6e69003] __libc_start_main (/lib/
[10:56:30.053] [000000000804da89] -- (/home/knut/xorg/WayX/usr/bin/weston)
read error: Interrupted system call
read error: No such file or directory
read error from connection 0x8273598: Connection reset by peer (104)
read error: Connection reset by peer
/home/knut/bin/testW: Zeile 9: 30862 Trace/Breakpoint ausgelöst (Speicherabzug geschrieben) $PREFIX/bin/weston --xserver

Xorg log
See attached document

-------------- next part --------------
A non-text attachment was scrubbed...
Name: Xorg.1.log
Type: text/x-log
Size: 12096 bytes
Desc: not available
URL: <>

More information about the wayland-devel mailing list